Hi, Amit here, I am the WPML Support Manager, our current ticket queue is quite calm and I'd like to encourage you to use our new chat support option

We are working hard to debug and look at every single report

All of the known issues are documented in https://wpml.org/known-issues/ you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

We are also adding once a week a tutorial to our YouTube channel - https://www.youtube.com/c/WPML-multilingual - check out if we already covered what you need and leave us a comment if you want us to produce anything there

If you do need to open a ticket please make sure to provide us with all the needed information as described here https://wpml.org/faq/checklist-before-opening-a-ticket-in-wpml-support/

We are very proud at our level of support, we are one team from all over the world and we are all experienced WordPress developers, you can read more about us here - https://wpml.org/forums/supporters/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.63 hours from now. Thank you for your understanding.

This topic contains 14 replies, has 3 voices.

Last updated by Bigul 5 years, 7 months ago.

Assigned support staff: Bigul.

Author Posts
May 25, 2013 at 5:43 pm #130383

Angharad

Hello,
I am very new to wordpress and the world of css, php and such and I have successfully built my site and translated the pages, my difficulty is that I cannot insert the language switcher correctly, the theme I am using is Flexography and it does not have a side bar on the front and category pages, but if I select header it does not show up. I have tried to "widgetize" a part of the header, but everything just froze when I tried to save it and now my site is blocked (the technitians at my service provider are looking into it). Could someone please advise me on how to insert the switcher into the header? I need to know exactly what to insert and where... working on my own just seems to create problems!
Thank you if you have taken the time to read this!
Angharad

May 26, 2013 at 5:22 am #130409

Harshad

Dear Angharad,

The drop-down language switcher can be added to your theme by inserting this PHP code:

<?php do_action('icl_language_selector'); ?>

Please add the above code to your theme's header.php file wherever you want to make it appear.

May 26, 2013 at 8:08 am #130421

Angharad

Thank you very much Harshad! It worked and I have the language switcher without crashing everything, but there is a little hiccup - I placed it in the header under "top menu" but it appears in both the top and the category menus... is there any way that I can make it appear only in the top menu?
Than you!
Angharad

May 26, 2013 at 8:12 am #130422

Angharad

Justo so you can see my site is hidden link

May 26, 2013 at 8:51 am #130423

Harshad

Dear Angharad,

You need to remove language switcher from wpml -> languages -> language switcher options.

May 26, 2013 at 9:20 am #130425

Angharad

Hello and thanks again,
I have removed the default language switcher and activated theis one:
"Display the language switcher in the WP Menu"
This option has a drop-down which allows me to select if I want the language switcher in the header menu or the category menu... if I leave it blank the switcher comes up in both menus, if I select one or the other the switcher disappears... I am sure it must be the tiniest little glitch because it is almost right!

May 26, 2013 at 9:38 am #130429

Harshad

Dear Angharad,

Did you uncheck the option to display language switcher in main menu?
Can you please attach a screenshot of wpml -> languages -> language switcher options screen?

May 26, 2013 at 10:42 am #130433

Angharad

Dear Harshad,
Yes, I am attaching a screenshot so that you can see... the problem is that if I select where to put the switcher it disappears...
I hope the screenshot is visible, I have never done this before and I really appreciate your patience!
Angharad

May 26, 2013 at 11:29 am #130443

Harshad

You need to uncheck the option "Display Language swticher in WP Menu".

May 26, 2013 at 12:24 pm #130447

Angharad

Hello again Harshad,
I have tried that too, but if I uncheck that it disappears again 🙁

May 26, 2013 at 12:29 pm #130448

Harshad

Dear Angharad,

Let me make it clear, you want to place the language switcher in header instead of main menu?

May 26, 2013 at 1:12 pm #130453

Angharad

Yes, and the code works it is just that there are two menus in my theme's header so it appears twice... but if I select which one I want ("top" or "category") it disappears again. I put it into the header php with the "top menu" but it comes up in both.

May 28, 2013 at 7:15 am #130817

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Dear Angharad,

You have two menus, header and main. You would like to place Language Switcher in Header menu, right ?

Are you created two menus using Themes>>Menus, for Header and Main ? If so please choose relevant menu in WPML>>Languages>>Language Switcher Options.

Please try and let me know your feedback.

--
With Regards

Bigul

June 21, 2013 at 6:51 pm #137997

Angharad

Hello,
I am still experiencing the same problem, the language switcher appears in the header but in BOTH of the menus (header and category) if I WPML gives me the option to choose which menu I want to put the switcher in but if I choose one or the other it disappears from both. So I either have two language switchers or none at all.
Any suggestions would be gratefully received!
Angharad

June 22, 2013 at 6:16 am #138042

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Dear Angharad,

Please share few screenshots for better understanding.


With Regards

Bigul

The topic ‘[Closed] Putting a language switcher in the header of the flexography theme’ is closed to new replies.