Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by guidoL-5 3 years, 10 months ago.

Assigned support staff: Thomas.

Author Posts
March 10, 2016 at 6:16 am #834424

guidoL-5

When I link a page/portfolio to an original language page/portfolio I face a issue where I cannot make any changes to the one I linked (the one which I link to original page). I am able to make changes to the original post though.

I am also facing a issue where the portfolios of secondary language redirect to the original language page if I don't link them ...

This may be happening due to the editor which comes with the theme I am using. Here is the theme link which I am using: themeforest.net/item/photography-responsive-photography-theme/13304399

I look forward to seeking from you guys ...

March 10, 2016 at 7:28 am #834470

Thomas

Hello and thank you for contacting WPML support!

Did you make Portfolio items and categories translatable?
Go to WPML -> Translation Management -> Multilingual Content setup tab, Scroll down to Custom Posts and Custom Taxonomies box.

Enable Translate option for Portfolio.

Then go to Portfolio menu in wordpress admin, you should able to translate portfolio items by clicking on + icon.

Please check your theme for WPML compatibility:

https://wpml.org/documentation/theme-compatibility/

For further information or if you have any questions related to this ticket please do not hesitate to contact us.

March 10, 2016 at 8:01 am #834501

guidoL-5

Hello Thomas,

I have already selected "Translate" option for Portfolios. And I am able to create translations for two different languages I have. The issue is that when ever I link two of those translations, I cannot make any changes to the one which I make child (not original)

March 10, 2016 at 8:22 am #834518

Thomas

Did you check your theme for compatibility?

This could be the problem:

### Translate vs Duplicate content ###

## Translate ##

To create a translation of post manually, please refer: https://wpml.org/documentation/translating-your-contents/creating-translations-manually/

If you created a post in English and later translate that to Chinese, then any modification in English post will not affect the Chinese translation.

## Duplicate post ##

This feature is mainly used when you want to display the original language post in other language. For more information on duplication post, please refer "Duplicating Content from the Editor" section at: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-using-content-duplication/

If you created a post in English and later duplicate that to Chinese, then any modification in English post will be copied to Chinese translation.

If you created a post in English and later duplicate that to Chinese, if you made changes to Chinese duplicate post, those changes will get lost because Chinese post is duplicate of English and it will be always synchronized with English post.

If you later decide to translate this Chinese duplicates post yourself, click on the plus sign (+) icon to edit them. There, WPML shows you that they are duplicates. Click on the button to translate them individually and start editing.

March 10, 2016 at 10:06 am #834642

guidoL-5

Thanks for the reply Thomas.

Just so you could understand more clearly I have created a video to recreate the problem I am facing. In the video I do the following steps:

1. Create a test portfolio in Dutch
2. Create a test portfolio in English
3. Link English portfolio to Dutch
4. Add a new text field in Dutch portfolio
5. When updating the content goes away.

Video: hidden link

I hope this makes things more clear for you ..

Thanks ..

March 10, 2016 at 10:07 am #834644

guidoL-5

And I checked, the theme is not listed under you compatibility list ..

March 10, 2016 at 12:24 pm #834809

Thomas

Thanks for sharing.

Did you make Portfolio items and categories translatable as suggested?

Go to WPML -> Translation Management -> Multilingual Content setup tab, Scroll down to Custom Posts and Custom Taxonomies box and see if portfolio is translateable.

Php and mysql needs to be a least version 5.6. You may contact your hosting provider.
WP Memory Limit has to be at least 128M.

March 10, 2016 at 2:10 pm #834928

guidoL-5

Thomas, I have already verified if "Translate" is selected for Portfolios and it is, please see the attached screenshots ..

About the versions and etc, I have attached a screenshot which has the system report generated by woocommerce plugin ..

March 10, 2016 at 2:40 pm #834970

Thomas

Thanks, looks good.

I see your PHP version is too low. Can you increase ot to 5.6?
MySQL also needs 5.6

You may talk to your hoster.

March 16, 2016 at 6:56 pm #839630

guidoL-5

Hey Thomas,

I updated the PHP version, but the problem is still there. What other suggestions do you have?

Also, is there any option from where I can set different home page for different languages?

March 17, 2016 at 7:18 am #839856

Thomas

Based on your screenshots: Did you translate them in String Translation?

WPML -> String Translation
Search for Strings you want to translate.

Display homepage in different languages:

https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

March 17, 2016 at 5:06 pm #840503

guidoL-5

The link you gave me to change homepage shows me how to manage language url structures. There is nothing there which states how I assign different Front Pages for languages.

March 18, 2016 at 12:04 pm #841115

Thomas

That doc shows how to set up language url formats and the ability to assign a start page.
When you have translated versions of a page they will be displayed in separate folders like
/en/ or /de/

If you want to assign complete different pages then you can only solve that with .htaccess

### Custom Work ###

It seems you need custom programming work which is beyond the scope of our support.
At this point I would suggest you consider contacting one of our certified partners from this link:

http://wpml.org/documentation/support/wpml-contractors/

You will get the custom assistance you need to get on with your project.
Before doing so please have a look also here:

http://wpml.org/documentation/support/wpml-contractors/guidelines-forpeople-looking-for-consulting-help/

March 18, 2016 at 12:04 pm #841116

Thomas

That doc shows how to set up language url formats and the ability to assign a start page.
When you have translated versions of a page they will be displayed in separate folders like
/en/ or /de/

If you want to assign complete different pages then you can only solve that with .htaccess

### Custom Work ###

It seems you need custom programming work which is beyond the scope of our support.
At this point I would suggest you consider contacting one of our certified partners from this link:

http://wpml.org/documentation/support/wpml-contractors/

You will get the custom assistance you need to get on with your project.
Before doing so please have a look also here:

http://wpml.org/documentation/support/wpml-contractors/guidelines-forpeople-looking-for-consulting-help/

March 22, 2016 at 6:37 pm #843844

guidoL-5

The Issue was due to a bug in theme. We switched to Visual Composer Plugin and its woking fine now ..