This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Hi, Amit here, I am the WPML Support Manager, please make sure you are using the latest WPML 4.3.15 before reporting an issue, thanks!

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This topic contains 5 replies, has 2 voices.

Last updated by Laura 14 hours ago.

Assigned support staff: Laura.

Author Posts
May 22, 2020 at 3:11 pm #6196555

callums

Tell us what you are trying to do? I was trying to using qTranslate Importer to migrate my site form qTranslate X plug in to WPML but it kept say "working for 1 hour" and my site is a small site without around 20 pages

Is there any documentation that you are following? I was following this thread https://wpml.org/documentation/related-projects/qtranslate-importer/

Is there a similar example that we can see?

What is the link to your site? hidden link

May 23, 2020 at 12:07 pm #6200921

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Also, please try to deactivate the Yoast SEO & qTranslate-X integration before proceeding.

June 1, 2020 at 12:22 am #6262161

callums

Hi, Could you help to take a look at the issue again ?
I deactivated the Yoast SEO & qTranslate-X integration before proceeding, increased PHP memory limit but the qTranslate Importer is still not working

Thanks

June 1, 2020 at 7:42 am #6263617

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

what does it means exactly "it's not working"? Can you make a video so we can understand better?

Also please check in the console browser and in the WordPress debug.log if there are any errors. To enable the debug.log, edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

June 1, 2020 at 1:51 pm #6265985

callums

Hi, I increased the WP Memory Limit but when run qTranslate Importer it kept showing working for more than 1 hour but nothing change.

June 3, 2020 at 9:51 am #6281697

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

in my previous post (https://wpml.org/forums/topic/qtranslate-importer-not-loading/#post-6263617) I explained how to enable the WordPress debug.log, please follow the instructions and see if you can find any errors.