This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.16 hours from now. Thank you for your understanding.

This topic contains 15 replies, has 3 voices.

Last updated by Itamar 3 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
March 27, 2018 at 2:08 pm

valentinaF-7

I'm trying to convert from qTranslate to WPML
- I've de-activated qTranslate X
- WPML activated, but not yet configured
- I've Installed & activated QT Importer
- I've clicked Options -> QT Importer

but when I click he give me the error :
Please save the qTranslate settings to the datbase first.
and it doesn't make the conversion

March 28, 2018 at 4:22 pm #1559272

valentinaF-7

I need an answer, I cannot use the WPML plugin if I can not convert from qTranslate!!
if I can not use it I have to ask for a refund !!

March 28, 2018 at 8:22 pm #1559457

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and sorry for the late response here.

This is a known issue that we have had recently.
It should be fixed with the latest version of the qTranslate X Importer plugin 1.9.2
Please update the qTranslate X Importer plugin on your site to its latest version and see if you can proceed with the importation of your translations from qTranslate.
https://wordpress.org/plugins/qtranslate-to-wpml-export/#developers

If it is not working, please let me know.

Thanks,
Itamar.

March 28, 2018 at 10:21 pm #1559545

valentinaF-7

Ok, I've updated the plugin, now it give me the message to rename the languages names.
ok I do it.
But when I go to Options - > QT importer
I saw that it does not list the names of the 5 languages I have active on qtranslate

it writes :

The following languages will be imported: . will be set as the default language.

March 28, 2018 at 10:36 pm #1559549

valentinaF-7

and the problem is also that when I click Start of the qTranslate Importer it starts to convert but it doesn't finish
it says always "Working... "

March 28, 2018 at 10:47 pm #1559552

valentinaF-7

after the importing it doesn't recognize correctly different languages, please see the screenshots

March 29, 2018 at 2:51 pm #1560195

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Thanks for updating the plugin and for providing the extra information.

If you agree, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

If you prefer to do it on your own, you can provide me with the snapshot of your website following these directions:
If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.
Duplicator instructions
- From WordPress plugin page, look for “Duplicator” and install it.
- Once installed, you get a new item in the main menu “Duplicator.”
- Chose “Packages.”
- Click on the first button you find in the toolbar on the right (“Create Package”)
- Give it a name or leave it as is
- Click on “Create Package Set.”
- Wait until the package is ready
- Click on “Installer”, then on “Package”: the first one is just a PHP script, the second one is a zip file containing everything you need
- Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big).
***********************
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to log in.
You may delete the new admin account once the snapshot has been built.
***********************
Once the problem is resolved, I will delete the local site.
***********************
IMPORTANT: Be sure to take a complete backup of your site and database first before you proceed!
***********************
Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please, could you provide me the additional Info and as well permit me to perform the required steps?

Thanks,
Itamar.

March 29, 2018 at 3:05 pm
April 1, 2018 at 8:26 pm #1561863

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hello and thank you for the access details.

I've installed the Duplicator plugin on your site and tried to create a duplicator package, but I had no success. I was asked to escalate this issue to our developers. I'm currently downloading the wp-content folder of your site and only the DB with the use of the Duplicator plugin to try and recreate your site locally for escalation.
While trying this, I've noticed the following which might explain the unsuccessful tried that you had when running the importation process from qTranslate to WPML.

By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if it help to make a successful importation process from qTranslate into WPML?

I'll wait for your response here.

Thanks,
Itamar.

April 3, 2018 at 6:54 am #1562894

valentinaF-7

Ok I've edit WordPress to 768 MB RAM

April 3, 2018 at 8:33 pm #1564080

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Thanks for increasing the WP_MEMORY_LIMIT.

So can you now import from qTranslate to WPML?
Is it not getting stuck like before?

April 16, 2018 at 7:21 am #1640597

valentinaF-7

yes I did several tests but nothing is solved. I even realized that it completely lost the translated version in other languages

April 16, 2018 at 10:43 am #1643486

valentinaF-7

the strangest thing is that on the qtranslate importer, where he writes "the following languages will be imported: " no language is listed, is empty

April 16, 2018 at 3:08 pm #1648369

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thank you for checking this.

I've created a copy of your site with the DUplicator plugin and escalated this issue to our second tier supporters, and they will continue to debug this issue.
We'll keep you updated here.

Thank you for your patience,
Itamar.

April 25, 2018 at 5:27 am #1801824

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Our developer has asked me to find out with if the default language that is set for WPML (Italian in your case) is also the default language that is set for WordPress in Settings -> General. I've checked it, and indeed it is the same language. Please see attached screenshot.

So the next step that our developer want you to check, please, is if the problem persists when you do the import again the content again with the qTranslate importer, but this time the default language should be set to English on both WPML and qTranslate.
Can you try it?

But when I look at your site now, the problem seems to be solved!
I look at the menu and at the footer where in the past we could see the problem of all the languages showing, and it looks alright now. Only the selected language is showing.
Can you see it?
Please see attached screenshot.
Have you fixed this problem?

Regards,
Itamar.