This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 7 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
March 12, 2019 at 12:41 pm #3322105

peterB-98

Please check here :- hidden link
As you can see all field is locked here i want to unlock it for all field because i used different data for both language. So please tell me how to do this?

March 13, 2019 at 3:33 am #3329625

peterB-98

I am still waiting for response.

Thanks

March 13, 2019 at 6:17 am #3330089

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

The translation preference for WooCommerce Custom fields is set in *wpml-config.xml* file of *wp-content/plugins/woocommerce-multilingual* folder. So we have to edit it. Please check the following documentation and attached images for more details.

https://wpml.org/documentation/support/language-configuration-files

https://wpml.org/documentation/support/language-configuration-files/#custom-fields

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

March 13, 2019 at 7:04 am #3330175

peterB-98

So i need to add this field in xml file correct?

March 13, 2019 at 12:21 pm #3333043

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. You have to edit the current WPML language configuration for Woocommerce Multilingual(*wpml-config.xml* file of *wp-content/plugins/woocommerce-multilingual* folder). For an example like the following.

From

<custom-field action="copy">_manage_stock</custom-field>

To

<custom-field action="translate">_manage_stock</custom-field>

Please check the following documentation for more details and let me know your feedback.

https://wpml.org/documentation/support/language-configuration-files

https://wpml.org/documentation/support/language-configuration-files/#custom-fields

--
Thanks!

Bigul