This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Rohan Sadanandan 3 months ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
July 16, 2019 at 8:10 am #4217503

alexanderA

Hello. I have used WPML to translate my site into both French and Chinese. I have an English language blog page, hidden link, i.e. the page designated to display my posts. I have duplicated this page into French (hidden link). I have neither duplicated nor translated it into Chinese. At the same time, I have also created many English language posts, and translated them into both French and Chinese (not duplicated--translated). If I open the URL where the Chinese blog page should exist--hidden link displays these Chinese language posts. Why exactly is that occurring? It has something to do with a WPML setting, is that correct?

Thanks.

July 16, 2019 at 9:56 am #4218623

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

From the details you have given, I assume that "blog" is a custom post type in your website

If so, you are viewing the posts in Chinese because you have already created translations for the blog entries in the Chinese language. It's working the correct way.

For controlling the custom posts translations, you need to navigate to WPML > Settings >
Post Types Translation.

You can read more about this here: https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

If you have any further doubts, please let me know.

Thanks,
Rohan

July 16, 2019 at 10:42 am #4219265

alexanderA

>> From the details you have given, I assume that "blog" is a custom post type in your website

Actually that is incorrect. 'blog' is the name I have given to a page on my site (see attached screenshot hh-blog-page). In-turn, in Dashboard-->Settings-->Reading I have specified this page as my "Posts page" (see attached screenshot hh-posts-page-settings). How does this affect the answer to my question?

July 16, 2019 at 4:14 pm #4222155

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The working of the page is normal.
The current setting is to display the page as Translatable.
That's why you can see the posts in the Chinese language.

You can read more about this here:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

If you have any doubts please let me know.

Thanks,
Rohan

July 16, 2019 at 4:19 pm #4222195

alexanderA

>> The working of the page is normal.

OK I understand that the page is working as expected. That's not really my issue though.

>> The current setting is to display the page as Translatable.

Can you be clearer as to exactly what you mean by that? *Why* exactly does the Chinese URL display the Chinese-language posts? What exact WPML setting(s) have been set such that the Chinese URL displays the Chinese-language posts?

>> You can read more about this here:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

I read that, but I'd still like you to explain if you can.

July 17, 2019 at 7:23 am #4226613

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

In WPML > Settings > Post Type Translations, you have selected the 2nd option: "Translatable - use translation if available or fallback to default language" (See attached screenshot)
When you select this option, if any translation is available for your content then it will show the translated content otherwise it will show the same content as in the original language.

Thanks,
Rohan

July 17, 2019 at 8:53 am #4227883

alexanderA

In your screenshot, you have circled the entry for 'pages.' But my issue pertains to 'posts.' But, I still understand what you are saying--thanks for explaining.

I have a follow-up question. As I mentioned, I have not translated the 'blog' page into Chinese language. But it still displays my Chinese posts. In light of that:

1. What would be the benefit of translating this page into Chinese?

2. Would there be any potential disadvantages of refraining from translating this page into Chinese?

July 17, 2019 at 10:58 am #4228977

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

In the settings, the "page" is circled because it's regarding your blog page.

If you want to translate any contents displayed from the page for eg. the page title or any other texts in the content area of the page then you need to create the translation of the page in the Chinese language.

Also, there are no disadvantages if you don't translate the page.

Thanks,
Rohan

July 17, 2019 at 11:20 am #4229361

alexanderA

>> In the settings, the "page" is circled because it's regarding your blog page.

OK right, that makes sense.

>> If you want to translate any contents displayed from the page for eg. the page title or any other texts in the content area of the page then you need to create the translation of the page in the Chinese language.

>> Also, there are no disadvantages if you don't translate the page.

OK thanks for that info. We can consider this resolved.

July 17, 2019 at 12:59 pm #4230203

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback.

Thanks,
Rohan