This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by rickM-9 2 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 12, 2019 at 11:06 pm

rickM-9

For the record, we started here and hit a dead end: https://wpml.org/forums/topic/questions-and-quizzes-under-sensei-lms-v2-1-2-are-not-recognized-by-wpml/

Here is the recap and screenshot again:

What are you trying to translate?
Courses, Lessons, Questions and quizzed created in Sensei LMS plugin.

What are you seeing? (please include a screenshot)
WPML is able to recognize courses, lessons, pages, etc, but is not able to recognize questions and quizzes. See attached screenshot.

What's missing or not working for you?
Previously in a staging site environment, WPML was able to show all questions and quizzes under Translation Management, and I was able to select them, make duplicates and push them for translations, Sensei version used was V1.9.6.
However, after the Sensei plugin was upgraded to V2.1.2, the questions and quizzes are no longer showing up in Translation Management in WPML.
We did a side-by-side comparison for the settings, it seems that in V1.9.2, questions and quizzes were automatically set to "Translatable" by WPML, but in V2.0.2, they were automatically set to "Not Translatable", I manually changed them but that didn't help.

Please let me know how to solve this issue, previously we were informed Sensei V2 should work just fine. See this post: hidden link

Also, the credentials and WP install below are a clone of our production site. We'll complete the translations with our partner Glyph (hidden link) who is very familiar with your platform. The guy I'm working with at Glyph is Yufan Yang (yufan.yang@glyphservices.com). In fact, he wrote most of the copy above on the previous forum request.

Thank you,

Joshua Abel
trout@imaginarytrout.com
480-332-6081
on behalf of Rick Means at Washington Retail Services (the website owner)

July 15, 2019 at 7:03 am #4207573

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

This may be a compatibility issue. The result is the same when I add language configuration for Question & Quiz post types in WPML>>Settings>>Custom XML configuration. Please check the attached image.

Therefore to debug the issue further I have created a test site in our Sandbox server. It is a fresh installation. Please visit the following URL.

hidden link

Please upload the Sensei plugins on the test site and check the bug is existing or not. It will help us a lot and we can forward the issue easily to our developers for further debugging.

Please try it and let me know your feedback.

--
Thanks!

Bigul

July 15, 2019 at 9:54 pm #4214719

rickM-9

Bigul, we went ahead and uploaded the core Sensei plugins (FYI Sensei is a free platform now, sans their plugin that allows the system to accept payment). This is not a simple test per se. Your sandbox should be a clone of our environment. I can provide an archive of the database and site files in an archive if that is something your team would like. In the meantime, I forwarded your message along to our translation team and I'm awaiting their response. Thank you!

July 16, 2019 at 2:14 pm #4220931

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

Thank you for the updates. Please note, the Sandbox test server is only for reproducing the compatibility issues in a fresh installation.

Please check the attached image. I am not able to reproduce the issue exactly in a fresh installation. Therefore please allows me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 16, 2019 at 3:11 pm #4221583

rickM-9

Bigul, feel free to install whatever you need in order to replicate the staging environment. You are free to do what you wish and have administrative privileges with the previously provided credentials. Let us know if there is an action you require from us.

Thanks!

July 16, 2019 at 7:21 pm #4223511

rickM-9

For the record, I don't think this is a plugin conflict. I disabled all plugins except for Sensei and WPML. No joy 😞 my guess is this is a logical issue or a query not picking up those custom post types and is either WPML (most likely) or Senei (unlikely). Your forums have this issue going back to 2014, and most recently in 2017 and April of 2018 users complaining about the exact same problem. Have a look at some of the results from this Google search: hidden link..69i57.19609j0j7&sourceid=chrome&ie=UTF-8

July 17, 2019 at 2:12 pm #4231055

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

Thank you for the details and permission. We had some compatibility issue with the plugin and it is fixed now.

I have tried to make a Duplicator copy using Duplicator free and Pro versions, but it failed. The result was the same after serval tries. Please check the attached images for more details.

Then I made a backup using All-in-One WP Migration now. Will debug the issue further and get back to you soon. Please wait.

--
Thanks!

Bigul

July 17, 2019 at 6:42 pm #4233007

rickM-9

Okay, thanks. As I mentioned I can provide you with a database and site file archive as a zip (complete backup) which are automatically created every day and on-demand as needed. Keep us posted.

July 18, 2019 at 2:31 pm #4239627

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

Thank you for the updates. The issue is existing after the initial debugging procedures. Therefore I have shared the details to our second tier team for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 18, 2019 at 10:52 pm #4242533

rickM-9

Okay, thank you.

July 22, 2019 at 7:58 pm #4261067

rickM-9

Any update from tier 2?

July 23, 2019 at 12:24 pm #4265931

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

For your kind information, the bug is existing after the primary troubleshooting steps. Therefore escalating the ticket to our second tier team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

July 25, 2019 at 6:23 am #4279481

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

For your kind updates the issue is happening because there is a wrong value in Database settings(*custom-types_readonly_config*) for these post types. It works in our local copy after the following steps. Please try it after a site backup and let me know your feedback.

1) Disable Sensei LMS plugin and its related add-ons
2) Go to WPML>>Settings>>Post Types Translation
3) Click on the save button of the section to refresh the settings
4) Activate the Sensei LMS and its related add-ons
5) Go to WPML>>Settings>>Post Types Translation
6) Click on the save button of the section to refresh the settings
7) Then visit WPML>>Translation Management Dashboard, the Questions and Quizzes post type will be listing

--
Thanks!

Bigul

July 25, 2019 at 3:13 pm #4284595

rickM-9

We followed your instructions as described in your previous message. However, it did not appear to resolve the issue. Freel free to try this yourself using the hidden link credentials provided to you. We have backups and this is not a production environment. If we need to make a database permission adjustment we're happy to do that in phpMyAdmin. Please advise, we need to resolve soon if possible.

Thanks!

July 25, 2019 at 4:26 pm #4285161

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Joshua,

Thank you for updates. The issue is existing on your site after these troubleshooting steps. So I have shared the details to our team and waiting for the feedback now. We will get back to you soon. Please wait.

--
Thanks!

Bigul