This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Noman 7 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
February 13, 2019 at 9:34 am #3192874

gari-amosA

Tell us what you are trying to do?
im trying to run the setup and when i click on the translation management tab in wordpress menu im getting the attached page result

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

February 13, 2019 at 11:18 am #3193544

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. We have released latest version of WPML v4.2.1, please backup your site and update WPML plugin and all its addons to the latest version:
https://wpml.org/account/downloads/

And let me know if this resolves your issue.

Thank you

February 13, 2019 at 11:26 am #3193566

gari-amosA

i updated all version still translation managemen is blank as on screenshot. i updated directly from wordpress

February 13, 2019 at 2:13 pm #3194508

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

February 14, 2019 at 9:31 am #3198380

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WP login info that you have provided is not working here. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

February 17, 2019 at 7:58 am #3208756

gari-amosA

any news?

February 17, 2019 at 8:50 am #3208817

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I ran into my weekend. I am working on it now and will get back to you today.

Thank you

February 17, 2019 at 10:27 am #3208889

gari-amosA

is it done?

February 17, 2019 at 11:01 am #3208953

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

No, I was working on it but looks like you are also working on the site at same time? I disabled plugins to test few things but someone re-activated plugins and then I stopped. I need the site to be free to debug it. So can I continue working on it if you are done with your work?

February 17, 2019 at 11:02 am #3208956

gari-amosA

ok go ahead. i give you a 2 hours window to do it. is it ok?

February 17, 2019 at 11:10 am #3208959

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

ok thanks, I will try my best to complete within this time. Thanks I will get back to you asap.

February 17, 2019 at 12:25 pm #3209107

gari-amosA

any improvement?

February 17, 2019 at 1:15 pm #3209152

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

I have enabled error reporting in your site and examined debug.log file from wp-content directory and found number of errors those are coming from database and some other plugins as follows:

- Shotrcode in Menus plugin error

[17-Feb-2019 11:20:18 UTC] PHP Notice:  Undefined property: stdClass::$object in /var/www/vhosts/marketbitplace.com/httpdocs/wp-content/plugins/shortcode-in-menus/includes/class-shortcode-in-menus.php on line 124
[17-Feb-2019 11:20:18 UTC] PHP Notice:  Undefined property: stdClass::$post_title in /var/www/vhosts/marketbitplace.com/httpdocs/wp-content/plugins/shortcode-in-menus/includes/class-shortcode-in-menus.php on line 127

- Database error

[17-Feb-2019 11:26:40 UTC] WordPress database error COLLATION 'utf8_general_ci' is not valid for CHARACTER SET 'utf8mb4' for query ALTER TABLE Xxm5380AC_icl_translation_batches CONVERT TO CHARACTER SET 'utf8mb4' COLLATE 'utf8_general_ci' made by do_action('wp_ajax_update-theme'), WP_Hook->do_action, WP_Hook->apply_filters, wp_ajax_update_theme, Theme_Upgrader->bulk_upgrade, do_action('upgrader_process_complete'), WP_Hook->do_action, WP_Hook->apply_filters, WPML_Table_Collate_Fix->fix_collate
[17-Feb-2019 11:26:40 UTC] WordPress database error COLLATION 'utf8_general_ci' is not valid for CHARACTER SET 'utf8mb4' for query ALTER TABLE Xxm5380AC_icl_translation_status CONVERT TO CHARACTER SET 'utf8mb4' COLLATE 'utf8_general_ci' made by do_action('wp_ajax_update-theme'), WP_Hook->do_action, WP_Hook->apply_filters, wp_ajax_update_theme, Theme_Upgrader->bulk_upgrade, do_action('upgrader_process_complete'), WP_Hook->do_action, WP_Hook->apply_filters, WPML_Table_Collate_Fix->fix_collate
[17-Feb-2019 11:26:40 UTC] WordPress database error COLLATION 'utf8_general_ci' is not valid for CHARACTER SET 'utf8mb4' for query ALTER TABLE Xxm5380AC_icl_translations CONVERT TO CHARACTER SET 'utf8mb4' COLLATE 'utf8_general_ci' made by do_action('wp_ajax_update-theme'), WP_Hook->do_action, WP_Hook->apply_filters, wp_ajax_update_theme, Theme_Upgrader->bulk_upgrade, do_action('upgrader_process_complete'), WP_Hook->do_action, WP_Hook->apply_filters, WPML_Table_Collate_Fix->fix_collate

It seems blank quick setup issue arising due to above database invalid COLLATION issue. To fixing this issue, could you please try below steps:

1- I believe replacing 'utf8_general_ci’ collation with ‘utf8mb4_unicode_ci’ will probably be the one that solves your problem.

2- Please upgrade your server’s MySQL version to a higher level: https://wpml.org/home/minimum-requirements/
MySQL 5.5.5 version in your site, is lower than the required for WPML.

Thank you

February 17, 2019 at 1:31 pm #3209177

gari-amosA

can you guide me trough this process in more details?

February 17, 2019 at 1:40 pm #3209202

gari-amosA

ill better ask to my hosting support to do so. will keep you updated