This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Duplicated ACF fields in the translation Editor

Solution: This is due to an empty field in a serialized array saved on "icl_sitepress_settings" option key in the wp_option database table. please open a ticket and we will patch it.

This topic contains 34 replies, has 3 voices.

Last updated by Alejandro 1 month, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
July 31, 2019 at 9:12 am #4313193

adrianG-8

I am trying to: translate a post with ACF fields.

Link to a page where the issue can be seen: It's a local website

I expected to see: I expected to see the fields I selected for translation to appear in the translation editor when I create a translation.

Instead, I got: This worked before but now there are suddenly all kinds of fields added with either codes or repeats from my selected fields. The field labels of these random fields are all "field-0" "field-6" "field-7" etc. There must be about 20 of them. It is not visible in the front end of the website but it really slows down my process if I have to tick 20 extra boxes for every translation.

I read somewhere on the Forum that you could higher your MaxInputVars to 10.000 because it could be causing issues if it is set too low. I tried changing it but that caused the website to not be able to connect and I had to set that back. I may have done it incorrectly, I'm not sure. Also I'm not sure if that's the solution to this. I hope you have an idea how to fix this.

Kind regards,

July 31, 2019 at 1:35 pm #4314787

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Can you please confirm that you are following our instructions at the following link on how to work with WPML and the ACF plugin?
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Indeed it is recommended to raise the MaxInputVars value in some instances. But I don't think that it is the solution in your case. Those fields are probably showing for translation because they are set to 'Translate'. Please review this section of our documentation.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#translate-option-pages

Regards,
Itamar.

August 1, 2019 at 2:05 am #4318109

adrianG-8

Hi Itamar,

I have followed the instructions when I created this and it worked fine so I continued working on other parts of the website. Once I came back to translate more posts I found all these fields. I checked with the Advanced translation editor and that one does not pick up all these fields. However, I am not using the Advanced translation editor because it separates every sentence of one of my text field and forces me to translate these individually. While the translated version sometimes has to be slightly different from the original and so I don't always use the same amount of sentences.

I checked the Custom Fields section in the Post and these fields are not in there (even when I click on "show system fields") so I cannot have selected them for translation.

Kind regards,

August 1, 2019 at 9:08 am #4320057

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

This is a weird case, which I wanted to have a look at. But since the site is on a local server, it is not possible at the moment. Let please proceed with the following procedure and later if needed I'll ask you to migrate your site to our test server.

I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like TwentyNineteen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to TwentyNineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons. Then please check if the problem persists. If it does not persist, so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

August 2, 2019 at 7:51 am #4327823

adrianG-8

Hi Itamar,

I will try what you suggested and otherwise I will look into migrating the website. You will probably hear from me again on Monday but how do I make sure the ticket doesn't get closed over the weekend?

Kind regards,

August 4, 2019 at 3:08 pm #4336603

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Ticket only get closed after a couple of weeks.
I'll wait for your reply.

Regards,
Itamar.

August 5, 2019 at 3:29 am #4337697

adrianG-8

Hi Itamar,

I had a look and set the Theme to Twenty Nineteen and then disabled all the plugins except for WPML and Custom Post UI (as I couldn't access the posts I wanted to translate otherwise), however the issue remained. Also I noticed this issue is occurring throughout the whole website (for both posts and pages).
I'm now looking into migrating the website but it may take a couple of days.

Kind regards,

August 5, 2019 at 5:03 pm #4342159

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

Please let me know when you are ready for the migration.
FYI, I can set up for you a test server on our Cloudways server (hidden link). The migration to the Cloudways server is done by installing a plugin on your site, and the process is quite easy. I prepare everything for and explain to you what to do.

I'll wait for your reply.
Itamar.

August 6, 2019 at 9:39 am #4345811

adrianG-8

Hi Itamar,

I migrated the website already. What details do you exactly need to proceed?

August 6, 2019 at 5:26 pm #4349727

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please let me have access to your site and I'll continue the check the issue.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/


**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

August 7, 2019 at 4:03 pm #4356671

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details to your staging site.

On your site, I've made some test and also switched the theme to a default WordPress theme and deactivated all the third-party plugins. The issue persists when only the ACF plugins and WPML and its add-ons are active. Currently, I'm trying to create a Duplicator package of your site to continue to check things on my local server and escalate this issue if needed. One thing is not clear to me, though.
Are you using the free version of the ACF plugin or the Pro version?
According to the plugins section, it looks like the free version, but when I tried to install the pro version on your site, I've received a message that the folder exists.

I look forward to your reply!

Itamar.

August 8, 2019 at 1:49 am #4358755

adrianG-8

Hi Itamar,

I just logged into the dashboard and deleted some of the old plugins that I think were from the old website as I did not install them on this new website. I'm sorry that may have made things more complicated, however I didn't realise they were all there.
I have been using the free version of ACF fields so far on this website but the Pro version is also installed and I activated that now to see if that would change anything (however it didn't).

Let me know if you can find anything!

Kind regards,

August 8, 2019 at 5:03 pm #4364909

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've installed the DUplicator package that you sent me on my local server, but something is wrong. It is not usable. I can't access the site or even see it. I've tried a few methods to fix this issue, but nothing worked.
Could you please migrate your site to our test server?
I'm adding all the needed details in the next private message.

Thanks,
Itamar.

August 9, 2019 at 4:58 am #4367375

adrianG-8

Hi Itamar,

I tried to migrate it. I installed the plugin, then filled out the details as you provided them but I got a message the migration failed because the website it Password Protected. It required to me to fill our more fields: Destination Site URL, sFTP Host/Serves address, Application folder name, sFTP Username and sFTP Password. I filled out all the fields except for the Server address and the Application Folder Name as I wasn't sure about those however I got an error: "Error! The destination site URL is incorrect. Please validate this URL and retry."

What do you suggest I do now?

Kind regards,

August 12, 2019 at 6:59 am #4378651

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This is weird, I've never heard such an issue with migrating to Cloudways. I'm not sure which site is password protected. The sites that we prepare on Cloudways are not password protected.
Can you please send me a screenshot of this screen were you say that you have fields to fill but missing the information?

Thanks,
Itamar.