This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 4, 2018 at 10:51 am #1973646

kevinK-20

I am trying to: We have asynchronous MySQL master-master replication between two nodes (only first node is used for administrative tasks). WPML plugin is installed on both nodes, and both instances are inserting randomly into wp_options an record for _icl_cache. Occasionaly (once per week), replication stops due Duplicate entry in the primary key - situation caused by WMPL while inserting new _icl_cache record.
Is there a way to disable those _icl_cache records ?

Thanks

May 7, 2018 at 5:09 am #2002852

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Are you using the latest version of WPML(3.9.4)? If not, please upgrade to the latest version after a backup and check the issue is existing. Becuase we have made improvements in WPML 3.9.

Please share me more details about the following for a better understanding.

We have asynchronous MySQL master-master replication between two nodes (only first node is used for administrative tasks).

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

May 7, 2018 at 5:40 pm #2018225

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I have a request. Please share with us the debug information for a better understanding of your site and its environment. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

May 8, 2018 at 6:46 am #2024063

kevinK-20

I've sent you the requested debug info. I would like to ask you if possible this ticket to be non-public.

Thanks,

May 8, 2018 at 5:08 pm #2037088

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the debug information. I have forwarded the details to our second tier team for the expert opinion and waiting for their feedback. We will get back to you soon. Please wait.

Please note, this is a public forum. So the forum users can read the threads, but the debug information will be private. Becuase of the system information, I have hidden your second last reply.

--
Thanks!

Bigul

May 9, 2018 at 11:05 am #2050576

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Our team has suggested adding the following code to *wp-config.php* file. Please try it and check is there any difference now.

define( 'ICL_DISABLE_CACHE', true );

--
Thanks!

Bigul

The topic ‘[Closed] random inserts in wp_options under option_name: _icl_cache’ is closed to new replies.