This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcel 2 months, 2 weeks ago.

Assigned support staff: Marcel.

Author Posts
July 31, 2019 at 7:05 am #4311985

simonK-26

I am trying to export a pages content as an XLIFF file. The export is successful (the file is properly generated and contains the pages whole content).

I expected to see continuous strings of text – like a single string per paragraph or logical entity.

Instead, I got randomly placed <br>-Tags with the class "xliff-newline" all over the content, making it close to impossible to work with the exported file, because all context for translation is lost in the process.

Is there a setting I missed?

July 31, 2019 at 8:11 am #4312711

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Simon,

Thank you for contacting WPML Support.

Could you please post me your settings under WPML -> Settings -> XLIFF file options "new lines character"?

Thank You
Best Marcel

July 31, 2019 at 8:18 am #4312727

simonK-26

Oh, did not know, this setting existed.
Its set to the second option "adding <br class="xliff-newline" />". Do you think, turning that option to "do nothing" might solve it?

July 31, 2019 at 8:33 am #4312917

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Please let me consult first our 2nd Tier to prove that this will solve the problem when the translation is coming from memoQ. Thank You.

July 31, 2019 at 10:18 am #4313645

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Simon,

yes, when you turn this function off, you can send the translation job again and those tags will disappear.

Please let me know how's it going.

Best Marcel

August 1, 2019 at 8:29 am #4319845

simonK-26

Hi Marcel,

it does not seem to fix the problem. Even after turning the function off, the strings are still full of tags (see attached image).
Do I have to delete existing translations jobs somehow, to get rid of the tags after turning off the function?

August 2, 2019 at 10:15 am #4328865

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Simon,

indeed it could be not working only for existing pages. Could you please test if this also happens when you send a new page?

(You can also write me in German 🙂 )

Best Marcel

The topic ‘[Closed] Random s in XLIFF export file’ is closed to new replies.