This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 2 voices.

Last updated by rafalP-12 1 week, 4 days ago.

Assigned support staff: Riffaz.

Author Posts
July 29, 2019 at 12:46 am #4296201

rafalP-12

Tell us what you are trying to do?
Trying to translate strings from Rating-Widget Plugin. It's this plugin:
https://wordpress.org/plugins/rating-widget/

Is there any documentation that you are following?
No

Is there a similar example that we can see?
Made a video of what I mean:
hidden link
I can also provide website access.

What is the link to your site?
rafalpiwinski.pl

July 29, 2019 at 5:05 am #4296981

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I could not find your plugin in our compatible list: https://wpml.org/documentation/plugins-compatibility/
So we have to check this in a fresh environment.

please,
1. go to hidden link
2. install your plugin
3. configure the WPML as you have it on your site. at the last step just click next (site key)
4. create only one page with the plugin you are using.
5. recreate the issue.
6. let us know how to check this and how to recreate this issue.
7. explain the step 6 with screenshots and URLs for better understanding.

Regards,
Riffaz.

July 29, 2019 at 11:49 pm #4303845

rafalP-12

Hi Riffaz,

I made what you wanted, but without mail I can't activate the Rating-Widget plugin. I added one product but without activating RW plugin it doesn't show stars. I added my mail there, but no confirmation was sent to me. I can give you access to my website and you can check what I mean instead of this sandbox. Radu has access already if you have contact.

Regards,
Rafal

July 30, 2019 at 11:49 am #4307467

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I added my mail there, but no confirmation was sent to me.
- did you check your spam folder?

It seems like a compatible issue.
So we need to check this in a fresh environment.
So we need to get it work in the bug free environment.

Let me know how and where do I have to add the email?
I can check with mine.

I will check your live site using the access details from your old tickets.
I will update you again once I find something.

Regards,

July 30, 2019 at 10:40 pm #4310723

rafalP-12

Hi Riffaz,

< did you check your spam folder? >
Yes, I checked, no email there.

< Let me know how and where do I have to add the email?
I can check with mine. >
I tried to put it to in demo profile section because there is no email and the plugin wants to connect using email, probably from there.
"Hey demo,
RatingWidget is a ratings service - the ratings data is stored on our servers. To use the plugin we need to connect your account to rating-widget.com and freemius.com."

< I will check your live site using the access details from your old tickets.
I will update you again once I find something. >
You can do there what you want it's for testing purpose, later it will be moved to live website if it will work.

Regards,
Rafal

August 1, 2019 at 5:41 am #4318903

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

The sandbox you provided has been expired: hidden link
Please use this: hidden link

Regards,

August 1, 2019 at 2:18 pm #4322667

rafalP-12

Hi Riffaz,

Yes I know it expired was only 24 hours - free version. I managed to set this install you gave, you can check it now.

Here you have strings I want to translate:
hidden link
Advanced Settings -> Text

And here are second one:
hidden link
Advanced Settings -> Text

These strings from there are not visible in String Translation
hidden link

Regards,
Rafal

August 5, 2019 at 11:14 am #4340059

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I've moved the sandbox site to a permanent server and our second tier support is checking this now.
Please be patient till we get back to you.

Regards,

August 19, 2019 at 6:25 am #4413677

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Our second tier tested this after changing the MaxInputVars to 20000 and it worked.

Steps:
1. Increase your MaxInputVars to 20000
2. Select the options in your plugin.
3. Save the settings.
4. go to WPML > String Translations and scrolldown to the very bottom and click on "Translate texts in admin screens"
5. go to rw_options > rw_woocommerce_products_options and rw_options > rw_blog_posts_options : hidden link
6. select them and save.
7. remove if you have any XML in WPML > Setting > Custom XML that are related to this
8. go to WPML > Theme and plugins loclizations
9. select rating widget and scan
10. go to WPML > String Translations and now you will see them and you can translate them,

Let me know how it goes.

Regards,

August 22, 2019 at 12:23 pm #4439235

rafalP-12

Hi,

Where is MaxInputVars? I don't see it anywhere.
What to select in rw_woocommerce_products_options and in rw_blog_posts_options? Here you have screens what is there:
hidden link
hidden link

Regards,
Rafal

August 22, 2019 at 4:05 pm #4440999

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please contact your hosting support to increase the MaxInputVars.
They will be able to do this within a minute.

And, you have to add all these: hidden link

Let me know how it goes.

Regards,

August 22, 2019 at 5:09 pm #4441791

rafalP-12

Hi,

I did how you wrote, but on frontend after translating these words, there is no change, still, they are in english instead of polish.

Regards,
Rafal

August 25, 2019 at 1:30 pm #4454105

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me know your live site login details.
The next reply is private.

Regards,

August 26, 2019 at 7:09 am #4456221

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

This is strange.
I escalated this to 2nd tier to check again.

Please be patient till we get back to you again.

Regards,

August 27, 2019 at 12:38 am #4461805

rafalP-12

Hi,

Thank you, will be waiting for further info.

Regards,
Rafal