Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: In WooCommerce the list of countries has an issue with those countries that start with special letters like Î or capital é. The order is wrong.

Solution: The issue is happening also without WPML and is a general issue in WooCommerce. The Github issue has been raised and it will be fixed by WooCommerce.

- https://github.com/woocommerce/woocommerce/issues/27415

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by jerisscloudcenter 1 year, 1 month ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
August 30, 2020 at 4:27 pm #6902055

jerisscloudcenter

I would like to re-open : https://wpml.org/forums/topic/list-of-countries-is-wrong-in-french/

I've tried the workaround given but it's not good at all. When I use this workaround, WooCommerce will use the alphabetical order of countries from the English instead of using the alphabetical order of the language on the screen).

See what it does : hidden link

Now as I pay for this support, I expect you to provide asap a fix for the issue I've provided in this initial video of the initial thread : hidden link

September 1, 2020 at 11:24 am #6914631

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Gevcen,

I have checked your video and also went over your previous ticket and workaround provided by our developers.

I am sorry you are having an issue, but as mentioned before this is not an issue directly related to WPML, there is not much we can do on our side. As an act of goodwill our developers provided a workaround, I am sorry it is not completely working correctly for you.

They provided a workaround that will disable the sorting of countries, so it is now using the default sorting.

From the previous ticket:


- Our third-tier supporter has checked this issue and found out that it is not directly related to WPML. This problem would happen even if WPML is not installed and you change the default language of the site from English to French in Settings -> General.


- As a workaround, you can disable the "sorting" by adding the following code to the functions.php file of your theme... It is essential for us to let you know that we would not support this workaround. We are giving it as an act of goodwill in hope that it would help you solve this problem.

I am sorry you are still having an issue but as explained this is not an issue caused by WPML and it happens also without WPML active, so there is not much we can do to fix it on our side.

I can see you already reported the issue in WC GitHub, and that is the correct way to proceed here. I am sure the fix will be released soon as the priory is set high.

- hidden link

Let me know if there is anything else I can do to help you out with WPML. 🙂

Thank you and regards,
Drazen

September 7, 2020 at 10:29 am #6956235

jerisscloudcenter

Github issue has been raised and it will be fixed by WooCommerce.