Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 3 voices.

Last updated by John-Pierre Cornelissen 4 weeks ago.

Assigned support staff: Sumit.

Author Posts
October 28, 2019 at 8:21 am #4836707

John-Pierre Cornelissen

Hi,

It's been two weeks this ticket has been escalated to 2nd line. The issue is still not solved and I didn't even receive a reply from them. Please let me know what the status is. My customer is getting impatient.

Thanks
JP

October 29, 2019 at 11:28 am #4846829

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello John-Pierre,

Unfortunately I still don't have any answer from our 2nd tier specialists.

Regards,
Carlos

October 30, 2019 at 11:43 am #4855085

John-Pierre Cornelissen

can you ask them for an update, considering it's been escalated already two weeks ago?

October 30, 2019 at 11:46 am #4855163

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John-Pierre,

I already did, I'm waiting for their answer. I will get back to you as soon as I get an answer.

Regards,
Carlos

November 5, 2019 at 1:25 pm #4889443

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi JP,

I am Sumit from 2nd tier support. I am sorry for the delay.

I have checked the website locally and as I can see the job is not completed in TextMaster? Please check the screenshot.

If the job is completed in the TextMaster then it seems to be stuck between the translation proxy and the translation service.
Before we debug further the easy way to check:-

#1 First let me know if the job is completed in Text Master?
#2 If it is completed then please ask Text Master if they support translation memory?
#3 If the translation memory is supported then update the original page and send it again to the text master the page will be auto-completed using translation memory and should be completed in WPML too. In this process, you don't need to pay any extra cost if there is no change in the original page since the translation is completed.

Is that possible for you?

Thanks

November 5, 2019 at 2:14 pm #4889887

John-Pierre Cornelissen

Hello Sumit,

#1 yes the job is completed in TextMaster it was completed on October 11 (see attached)
- at 00:49 it was completed the first time
- at 15:33 it was completed the second time after I asked them to resend the translation because I did not receive it correctly in WPML.

The incomplete job you see is not the original job. The one you see is from October 15 and a result from Carlos testing a few things as he mentioned here
https://wpml.org/forums/topic/received-translation-from-service-no-correctly-imported/#post-4756429

I guess he had resent it to TextMaster, but got stuck from there. I have cancelled that new job in TextMaster now so in WPML it's cancelled now too.

From the wpml translation jobs tab (also attached) you can also see that Carlos has tried to resent the job to himself (support user) and then completed the job without having the actual translations.

#2 no this project doesn't have translation memory. But I can download the completed xliff file. It's the google drive link in my original support request. But if I manually import that, I get an error "The translation job (8) doesn't belong to you.".

#3 So there is not translation memory. I only have the xliff file that contains the translations and they somehow need to go in WPML. Since importing the xliff results in an error I need your help there.

Thanks
JP

November 6, 2019 at 2:32 pm #4899221

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Okay. I checked with the translation proxy team the job has been cancelled so they can not check what was the problem with original job.
The only option, for now, is to import the translation manually but for this, both the files do not match so I am checking with my team if we can convert the original file from TextMaster to WPML compatible file so it can be imported manually.

I will keep you posted.

Thank you for your patience.

November 7, 2019 at 12:15 pm #4905737

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi JP,

We have found the way and it works on my local copy. We will convert the file that you have provided to WPML compatible format and then we will import this to the site.

For this, I need the working credentials of your website, I will send the job to the local translator (myself) and then I will upload the translation. I am enabling the private reply.

Please make sure to create a backup of the site (Just a good practice!)

Thanks

November 7, 2019 at 2:04 pm #4906565

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

The translation is uploaded successfully. Please check here hidden link

>Will this be an import that is Advanced Translation Editor compatible?
Sorry, I don't understand what do you mean? ATE and Translation service does not have any relation. You can consider them as two separated translation services.

Thanks

November 7, 2019 at 2:52 pm #4907141

John-Pierre Cornelissen

Thanks

Ok, I just tried to edit the translations you imported. I clicked the pencil icon to update the translation of this page. It opens the Advanced Translation Editor but it doesn't show the translations you just imported. The translation are there on the front end, but if I want to change something on the back end, there is nothing there.

So it looks like the translations you imported are not compatible with the ATE. Can you fix that so I can edit the translation when I need to?

--
There are more pages with that compatibility issue on this website. That's all described in my other outstanding ticket. After this site was translation by TextMaster, I checked if everything was fine. And it wasn't:
- some pages opened with the ATE with their translations
- some pages opened with the ATE without their translations (like the page you imported)
- some pages opened with the classic editor with their translations
Examples here: https://wpml.org/forums/topic/translation-opens-in-classic-editor-instead-of-ate/page/2/#post-4767787

That ticket is 4 weeks open now, and after my last message 2 weeks ago it looks like that ticket is being ignored.

Thanks
JP

November 8, 2019 at 11:20 am #4912731

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am really sorry I have asked Carlos to check the issue and Amit or someone from our team will continue very soon.

However, I would like to explain how things work.

ATE
As I stated in the previous reply you can consider ATE as a separated translation service with the one-way process.
ATE can only send the translation to WPML but WPML can not send the translation to ATE.
So once it is translated using TextMaster and then you send it to ATE, ATE receives the completely untranslated file. Sometimes you see the translation in ATE because of the translation memory.

Classic Translation Editor
CTE uses the site database, unlike ATE which uses the WPML servers. So whatever you translate using translation service it is stored in the database and classic translation editor can use it.

You can clearly see both the translation editor has different workflows. So what you are seeing is completely expected.

What if WPML sends existing translation to ATE
It is not like that we don't know how useful this can be but there are many factors including the complexity of this feature.
Amit will continue on the other ticket about this issue. However, I can tell you that there is no issues it is by design. But we are open to feature requests https://wpml.org/suggest-a-new-feature-for-wpml/

Thanks

November 8, 2019 at 12:02 pm #4913039

John-Pierre Cornelissen

Hi,

Regarding: Sometimes you see the translation in ATE because of the translation memory.
» That is not the case. This site was not translated before, so there wasn't any translation memory. I also didn't click the 'auto translate' option. So the translation came from somewhere.

But ok, that's another discussion.

For this ticket, how can I edit the translations you imported?
If I try to, it opens the ATE without the translations, so there must be another way.

Thanks
JP

November 8, 2019 at 1:44 pm #4913773

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I haven't debugged yet but believe me, it might be memory or machine translation because WPML does not send the existing translation to ATE or Translation services.

About the translation being opened in ATE, yes this is a bug that is reported already and will be fixed in the future.
Actually, what happens by design should open ATE for a new translation and for the items which have been translated using CTE should open CTE but there is a bug.
When you update the original content and then it opens ATE thus losing existing translation even you have selected CTE for old content.

I have found a workaround:-
#1 Please add this to functions.php

add_filter('wpml_tm_ate_jobs_editor_url', function ( $url ){
    if ( isset($_GET['noate']) ) {
	return false; 
    }
    return $url;
});

#2 Then do not click edit link but copy the link then paste in new tab and add &noate at the end of URL, hit enter. It should open CTE and next time you will see CTE as well.

Does it work for you?

Thanks

November 8, 2019 at 4:06 pm #4914781

John-Pierre Cornelissen

Thanks for explaining. Did you just find that bug or is that a know issue all along?

So I guess the setting as in the attached screenshot is part of the problem. I had it set like that because translation from TextMaster are sentence based segments just like the ATE, so I assumed that would be fully compatible.

I have changed both settings to CTE now and that works for this page. I'll check the other pages next week.

JP

November 12, 2019 at 10:15 am #4930497

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi JP,

The issue is already reported and known. It just the workaround I found for this ticket.
Since you have changed the setting to CTE then ATE is completely disabled so the above code is not needed but in case you wish to use ATE only for a new translation and CTE for old translation you can follow the steps from the previous message.

Thanks