This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 8 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
January 29, 2019 at 12:24 am #3137704

Doug Alexander

Dear WPML Team,

This is not an issue that occurs on the live page, but rather one that happens in the WordPress admin.

With the most recent update to Advanced Custom Fields Multilingual I noticed a line of text under every single field in my editor. The line says, "Field's value in original language:" but nothing follows that text (And, even if it actually had the value, I would still want to remove it because it really clutters up the page).

I have searched for a way to remove this text, but have not found the appropriate setting. Can you please advise?

Thanks,

January 29, 2019 at 2:45 am #3138083

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

January 31, 2019 at 6:29 pm #3149342

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took a closer look in your WordPress Dashboard and couldn't notice the mentioned issues in your staging environment as you can see in the provided screenshot. Please, let me know if you still see the issue happening in your WordPress Dashboard pages and posts custom fields. Have a nice day.

January 31, 2019 at 9:25 pm #3149729

Doug Alexander

This issue is not present on the English version of the site.

Did you take a look at any of the other languages? I think the original image I sent you was on the German version of the site. The one I am uploading now is from Italian.

February 1, 2019 at 2:56 pm #3152157

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the additional clarifications. This message is really coming from the most recent versions of the ACFML plugin and the purpose of it is to serve as an aid for translators when they are translating, so they can look at the original value. When there are many fields, it can be helpful to see what the field contains in the default language, especially if the fields are not named properly.

Unless you are not seeing any issues with these translations, you can omit that message. Also, you may want to try translating custom fields using Standard Translation Editor - this message will not be there and will be easier to manage/translate these.

https://wpml.org/documentation/translating-your-contents/translation-tools-available-with-wpml/

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

If you still want to hide it, then you can proceed like this:

1 - Install the plugin https://wordpress.org/plugins/add-admin-css/ in order to be able to target custom css code for your WordPress Dashboard elements.

2 - Now in the proper custom css field of the mentioned plugin above, enter something like:

.wpml_acf_original_value {
display: none!important;
}

Please, let me know if you need any additional clarifications, have a nice day.