This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by shouno@4d2a.com 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 18, 2019 at 1:57 am #4234087

shouno@4d2a.com

I am trying to: I'm trying to redirect the page in jp to page in en.
hidden link -> hidden link

Link to a page where the issue can be seen:

hidden link

I expected to see:

Instead, I got:

but it does not seem to be work.

July 18, 2019 at 2:39 am #4234337

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Have you tried using a plugin to do this redirect, such as "Redirection" (https://wordpress.org/plugins/redirection/)? With this plugin, you can redirect pages.

Please, let me know if using this plugin you can redirect the pages as desired.

Thank you.

July 18, 2019 at 6:40 am #4235371

shouno@4d2a.com

Thank you for your help. But I am sorry for not explaining sufficiently. What I wanted to do is redirection by user language setting. Is it possible?

July 18, 2019 at 4:16 pm #4240955

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry, but I still do not understand. Do you want to redirect the user based on the language of the browser? If yes, WPML has the redirect feature (only the first time): https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

If not what you're talking about, could you please elaborate a little more so that I can understand better?

Thank you.

July 19, 2019 at 6:45 am #4244237

shouno@4d2a.com

Yes, exactry. But on oursite it didn't seems to work well. I tested that by changing browser language setting.

July 19, 2019 at 4:14 pm #4247453

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This works correctly for me. When I access the link you posted above, the page is redirected to the secondary language (English) because my browser is set to English.

Note that redirection is only done once. Then the redirect is not done anymore. According to our documentation:

No Redirection When Refreshing the Browser

WPML will do this language redirect only once and then not redirect anymore. We do this to allow visitors to still switch languages. If we always push back to the browser’s language, visitors will not be able to manually switch languages after WPML redirects them to the language set by their browser.

This single-time redirect operation resets every 24 hours (which you can change too)

Have you tried to access the link you posted above in an "anonymous/incognito" tab of your browser? Or clear your browser's cache and cookies and try again? Note that redirection is only done once and the browser, in your case, must be set to English for the redirection to take place.

Thank you.

July 20, 2019 at 2:19 am #4248735

shouno@4d2a.com

I appresiated your support. Thank you!