This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Bigul 2 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 23, 2019 at 12:21 pm #4265927

jakeA-3

Hey,

I'm having issues with the automatic translations of URL's that are within the page content, for example the link in english is '/about-us/this-is-us/heritage', however on the German version of the site I need this to change to '/de/about-us/this-is-us/heritage'..

1/ I've had a look around the forum and it looks like running the 'Translate Link Targets' will fix this issue, is this correct?

2/ Every time that I attempt to run the 'Translate Link Targets' it's been freezing about half way through. Is there a way to limit the amount of strings that it's searching? It's currently trying to search through 22,755 strings.

It'd be great to get this sorted before plugging in all of the content in all of the languages!

July 23, 2019 at 5:27 pm #4268439

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

*Translate Link Targets* feature may miss the links of Page Builder elements. Are you using a Page Builder?

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

July 23, 2019 at 8:23 pm #4268845

jakeA-3

Hey Bigul,

Thanks for the assistance with this!

I'm using purely custom fields with the standard WYSIWYG editor, so no 3rd party page builder is being used.

Would you like me to paste the debug info directly here? Or should I be putting this somewhere private?

Many thanks,

Jake.

July 24, 2019 at 8:09 am #4271271

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jake,

Thank you for the updates. I have enabled the Debug Information option for this topic. Please share the data in *Debug Information* field.

Please check the following documentation for more details.

https://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

July 25, 2019 at 8:39 am #4280879

jakeA-3

Hey Bigul,

Thanks! That field wasn't showing when I tried to reply last time.

I've added the debug info in.

Thanks!

July 25, 2019 at 2:33 pm #4284253

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the Debug information. I have a request. Please upgrade the following configuration for the expected performance of your site and check you are getting the expected result or not.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

3) Visit WPML>>Languages>>Make themes work multilingual, enable *Adjust IDs for multilingual functionality* option

4) Visit WPML>>Languages>>Language filtering for AJAX operations, enable *Store a language cookie to support language filtering for AJAX* option

--
Thanks!

Bigul

July 29, 2019 at 3:51 pm #4301541

jakeA-3

Hey,

I've managed to run through a few of these steps and the 'Translate Link Targets' has now successfully completed, so thanks for that!

However, my links are still not forwarding over to the correct language - could you please advise?

Best wishes,

Jake.

July 29, 2019 at 6:10 pm #4302751

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jake,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please share me the exact steps to reproduce the issue on your site.

--
Thanks!

Bigul

July 30, 2019 at 6:20 am #4305003

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jake,

Thank you for the details and login information. But I am not able to access the site because of ERROR: Incorrect username or password issue. Please check it.

--
Thanks!

Bigul

July 30, 2019 at 7:40 am #4305379

jakeA-3

Hi Bigul,

I've reset the password to match the previous reply and tested, should be working now!

Thank you.

July 30, 2019 at 2:40 pm #4308565

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jake,

Thank you for the updates. I can login to the site now. Just to make sure the issue is only happening with the *Find out more* links?

Please note, I had a *database connection issue* on your site a couple times while visiting the Dashboard pages. Check the attached images for more details.

--
Thanks!

Bigul

July 30, 2019 at 2:45 pm #4308697

jakeA-3

Hey Bigul,

That's correct! Using the navigation is completely fine and will navigate through the en/fr/de sites.

When I clear my server cache or switch to development mode with my host I get the 503 errors, so that shouldn't be an issue 🙂

July 31, 2019 at 9:26 am #4313271

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Jake,

I have checked about this issue with our team. Sorry to inform you that as of now there are some limitations to translate the links of Custom fields automatically using *Translate Link Targets* feature. Now it will only translate the URLs of Post Contents.

Please visit this ticket thread for the possible workarounds - https://wpml.org/forums/topic/link-field-of-acf-should-point-to-translated-page/#post-2746499

Maybe our Sticky links plugin will help you to some extent. Because it will find URLs and convert them to use as Page Ids - https://wpml.org/documentation/getting-started-guide/sticky-links/. Please only try it after a full site backup.

Please check it and let me know your feedback.

--
Thanks!

Bigul

The topic ‘[Closed] Reduce the amount of strings in Translate Link Targets’ is closed to new replies.