This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Should I register the test site URL or the final website URL?

Solution:

You need to register the site/URL that you are working on. Do not register another URL. When you will move your site to the live URL change the registration and the key.

Relevant Documentation:

https://wpml.org/faq/install-wpml/

This topic contains 4 replies, has 2 voices.

Last updated by brendav-3 5 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 30, 2019 at 9:43 pm #3715047

brendav-3

Tell us what you are trying to do?

I am setting up WMPL and am unclear whether I should be registering the URL for the staging site or the final URL? I am working on a redesign of an existing website so the URL is live elsewhere. If this makes sense.

What is the link to your site?

testicakcanada.avocavale.com

May 2, 2019 at 4:21 pm #3726825

brendav-3

Thanks, that was helpful.

Also: Can I change the way it looks in my dashboard so instead of a British and French flag, I see EN or English and FR or French? We are in Canada and those flags are a bit disconcerting!

Thanks!

May 2, 2019 at 4:56 pm #3727325

brendav-3

Also: In the settings > How to translate posts and pages > New content
Should I select:
Use WPML's Advanced Translation Editor
...when I have all the translated text for the website? There are also forms etc that will require translation.

May 2, 2019 at 4:59 pm #3727365

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

This is the URL where you can register a site.
https://wpml.org/account/sites/
Please see the attached screenshot.
Is this where you are having the problem that you describe?
...it takes me back to the login page. Keeps doing that.
If so can you please clear the browser cache or try to log in on another browser?
Please read our documentation on how to install and register WPML.
https://wpml.org/faq/install-wpml/

At the following link, you can find a detailed explanation about how to switch a flag for a specific language.
https://wpml.org/2019/01/choosing-the-flags-for-your-sites-languages/

I hope that this information is helpful to you.

Regards,
Itamar.

May 2, 2019 at 8:14 pm #3728997

brendav-3

My issue is resolved now. Thank you!