This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 3 voices.

Last updated by vasiliyM 5 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 10, 2019 at 1:34 pm #3576669

vasiliyM

I am trying to: Update WPML and Addons. Deleted registration and trying to register again with newly generated keys but it does not work. Next renewal: 2019-17-09.

April 10, 2019 at 1:46 pm #3576913

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please send me a screenshot of the link that you added in your WPML.org account, under the Sites section? I am setting your next reply to be private.

Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 11, 2019 at 9:52 am #3585825

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the feedback.

From what I can see, you should create a key for this link - hidden link; - instead, from what I can see, you created a key for the non-https version so please use that exact link I sent to you in bold above.

You should practically use the link that you can find in your WordPress panel > Settings > General.

So just remove the current keys that you created in your WPML.org and create new keys for the correct link. Then go to Your WordPress dashboard > Plugins > Add New > Commercial and add the new WPML key.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

April 11, 2019 at 10:25 am #3586049

vasiliyM

I tried both variants (http and https) so noting works(

April 12, 2019 at 9:20 am #3596985

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the update.

Can you please then try this:

❌ Before proceeding please make a full website backup! ❌

  • download the latest version of WPML from https://wpml.org/account/downloads/;
  • disable WPML Multilingual CMS
  • delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted);
  • upload the freshly downloaded WPML plugin from Plugins → Add New → Upload Plugin
    → Activate WPML
    ;

Please let me know if it works now.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

April 13, 2019 at 9:06 am #3604019

vasiliyM

I can't disable or delete it(

April 15, 2019 at 1:23 pm #3613733

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I went to your website's backend > Plugins (hidden link) > and was able to simply find the WPML plugin (I will attach a screenshot). I was able to test the "Deaktivieren" button and it worked ok, so you can use that button to deactivate it and then you can use the "Löschen" button to delete the plugin.

Please DO NOT forget to first create a full site backup.

Here is the process that I refer to:
hidden link

You will find in the link above how to activate or deactivate a plugin.

I hope that you will find this information helpful! 🙂

Kind regards,
Mihai

April 16, 2019 at 7:04 am #3618589

vasiliyM

So, it helped for hidden link!

But it doesn't help with hidden link

April 16, 2019 at 7:35 am #3619065

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am glad to hear that we are making progress 🙂

Can you please share the access credentials for the other site?

I will enable the private fields below and I will be waiting for your response.

Kind regards,
Mihai

April 16, 2019 at 11:38 am #3621531

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for the credentials.

I can confirm that they work.

I was also able to check your profile and from what I can see, you added the link correctly under your WPML.org account.

Can you please let me know:

1. what are the exact steps that you are taking
2. and what is the error that you are seeing after you add the key into your site's backend?

If you can create a screen recording video with the exact steps, that would be even better so that I can better understand what are you dealing with and what is the process that you follow.

Please let me know.

I will be waiting for your response.

Kind regards,
Mihai

April 16, 2019 at 7:54 pm #3625249

vasiliyM

All the same as the solution for first website here

April 17, 2019 at 8:09 am #3628337

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your answer.

Can you please try the solution in the ticket below and let me know if any make any difference:

- https://wpml.org/forums/topic/i-cant-register-wpml-in-my-site/

If what is recommended in the ticket above doesn't work, please follow the steps from this ticket below once again but this time, first delete the current key in your WPML.org and generate a new one for the same link: hidden link

- https://wpml.org/forums/topic/cant-register-the-plugin/#post-3532957

Now try to register using the new key.

If that still doesn't work, please create a full backup of your current site and then disable all the non-WPML plugins and change the theme to a default WordPress theme like Twentyseventeen.

Now try to register again.

Please let me know if that solved the issue.

Kind regards,
Mihai

April 17, 2019 at 3:45 pm #3632421

vasiliyM

For the first solution there is no Checkbox 'Keep wpml.org up-to-date about which theme and plugins I use' option"

Second solution from here - doesn't helps too

April 18, 2019 at 8:01 am #3636967

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I debugged deeper and it seems that whenever you try to register the plugin, you are getting a 500 error in the browser console (attaching screenshot).

1. To further check on what's happening, I will need you to please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

In order to do that, edit the wp-config.php file inside your WordPress directory and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Now please reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the content (if any) on a site like pastebin.com and then share the link here with me. Please censor any sensitive information.

2. Also, I will need FTP access for the bas-galerie site. I am enabling the private fields below once again.

I will be waiting for your response.

Kind regards,
Mihai

April 22, 2019 at 3:32 pm #3656679

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the updates and for the FTP access.

Indeed, it seems the debug.log doesn't get filled with any information, not even after I repeated the registering process.

However, I was able to go here (hidden link) and I was able to see an error that is repeating itself.

I got in touch with one of our developers and he told me that it seems the PHP version might not "like" our secure certificate - something might be outdated there.

The hosting has to take care of issues like this, for example, on Ubuntu servers you can run:

sudo update-ca-certificates

- but you won't be able to do that on your own unless you have a dedicated server

I recommend that you contact your hosting support for help regarding this matter and I am also attaching the screenshot. Whenever you try to register our plugin, you receive a 500 error in the browser console which is not expected.

Please let me know what you will be able to find as that information might be very valuable for people who might find themselves in the same situation in the future.

Kind regards,
Mihai