This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.

This thread is resolved. Here is a description of the problem and solution.

Problem:Registration problem

Solution:This error might also be happening due to the repositories.xml missing from /vendor/otgs/installer.

Go to wp-content\plugins\sitepress-multilingual-cms\vendor\otgs\installer using FTP and from place the repositories.xml file .

repositories.xml file:
=>https://plugins.svn.wordpress.org/woocommerce-multilingual/trunk/vendor/otgs/installer/repositories.xml

Once thats done you need to press "Check for updates"

Relevant Documentation:

Related documentation: How to Download and Install WPML and Receive Automated Updates

This topic contains 13 replies, has 2 voices, and was last updated by  Michal 4 months, 2 weeks ago. The support staff assigned to this topic is Bobby.

Author Posts
Author Posts
April 6, 2017 at 7:41 pm #1249248

Michal

Hello WPML team,

I want register WPML plugin to get automatic updates.
Inserting site key cause me error mesage about wrong URL during quick setup and I skipped it. Now is visible button Register WPML as on first attached picture. But when I click on button request is redirected to page with commerical plugins and I can't do anything.
My site is not accessible from whole Internet for visitors now, but I can eg. install plugins from WordPress repository.
I want block unknow external HTTP requests by WordPress parameter WP_HTTP_BLOCK_EXTERNAL, but I tried disable for while and nothing changed with my registration problem. Please define which hosts must be accessible for WordPress parameter WP_ACCESSIBLE_HOSTS, In similar request I found host "d2salfytceyqoe.cloudfront.net" but I am not sure it is correct and only one.

April 6, 2017 at 7:45 pm #1249251

Michal

I forgot attach screenshots...

April 6, 2017 at 9:35 pm #1249311

Bobby
Forum moderator

Supporter languages: English (English )

Supporter Timezone: Europe/Athens (GMT+03:00)

Hello,

Perhaps you don't have a DNS server that can resolve our servers or you might have some restrictions because of a firewall.

It is recommended to whitelist our servers api.wpml.org with IP 74.50.57.129 and wpml.org with IP 74.50.57.118 and test again.

please contact your hosting company and ask if their firewall is blocking access to WPML.org API ( api.wpml.org ) ?

we have two different calls being made so that installer can run and the WPML plugins can be updated.
One is the Amazon Cloud service where the initial URL would be: http://d2salfytceyqoe.cloudfront.net/ and the IP is 54.192.129.188 ( note that this being an external service the IP can change, we have no control over it )
The other is to the WPML specific API with the following IP: 74.50.57.24

Note : This may take some time to update to re-fetch the repositories again.

You can try installing any cron tasks management plugin and run the task for this manually.

April 7, 2017 at 8:42 am #1249548

Michal

Hello Bobby,

I have own server for hosting WordPress and everything is under my control.
Outgoing requests are not blocked by any firewall, only by WordPress configuration where I have:

define('WP_HTTP_BLOCK_EXTERNAL', true);
define('WP_ACCESSIBLE_HOSTS', 'api.wordpress.org,downloads.wordpress.org,wpml.org,api.wpml.org,d2salfytceyqoe.cloudfront.net');

I tried temporarily disable WP_HTTP_BLOCK_EXTERNAL, but nothing changed.

DNS resolving works fine, both api.wpml.org and wpml.org direct to IP address 74.50.57.24.

Is there anything what I can try?

April 7, 2017 at 4:54 pm #1250131

Bobby
Forum moderator

Supporter languages: English (English )

Supporter Timezone: Europe/Athens (GMT+03:00)

Hello,

Did you just add our IP addresses ? do note that it might take some time for the repositories to re-fetch

Try and go to Updates > Check for new updates and try to run them if any.

April 10, 2017 at 10:00 am #1250943

Michal

Hello,

Where do I add your address?
I tried search new updates (/wp-admin/update-core.php?force-check=1) but nothing changed.

Why is view of commercial plugins empty? (No repositories defined.)
Is there something what I can to do?

April 10, 2017 at 5:19 pm #1251446

Bobby
Forum moderator

Supporter languages: English (English )

Supporter Timezone: Europe/Athens (GMT+03:00)

May i kindly ask you to please share with me the contents of your .htaccess folder .

Q : Why is view of commercial plugins empty? (No repositories defined.)
Is there something what I can to do?

A : This usually happens when your host cant reach our servers.
The quick way around it would be to manually update WPML by downloading our plugins from
=>https://wpml.org/account/downloads/

April 10, 2017 at 8:30 pm #1251566

Michal

Sure, my .htaccess file in DocumentRoot has content which created WordPress, nothing special:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Workaround with manual download for update WPML is clear.

April 10, 2017 at 11:49 pm #1251625

Bobby
Forum moderator

Supporter languages: English (English )

Supporter Timezone: Europe/Athens (GMT+03:00)

Hello,

If you are using Apache, please review the following documentation regarding on how to Allow hosts , and make sure you have allowed our IP's correctly for apache.

May 29, 2017 at 8:41 am #1286192

Michal

Hello,
sorry for delay. I changed the settings according to your advice.
I allowed access from you IP addresses:
- 74.50.57.24
- 74.50.57.118
- 74.50.57.129
WordPresss parameter WP_ACCESSIBLE_HOSTS contains:
- wpml.org
- api.wpml.org
- d2salfytceyqoe.cloudfront.net

But nothing changed, registration of plugin is still needed.
Do you have another idea?

May 29, 2017 at 9:28 pm #1286848

Bobby
Forum moderator

Supporter languages: English (English )

Supporter Timezone: Europe/Athens (GMT+03:00)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

May 31, 2017 at 12:05 pm #1288297

Michal

Grant access to the production environment will not be possible. Is it really not possible to try something else?
Maybe I could prepare another test environment, but it could take several weeks...

May 31, 2017 at 6:00 pm #1288718

Bobby
Forum moderator

Supporter languages: English (English )

Supporter Timezone: Europe/Athens (GMT+03:00)

This error might also be happening due to the repositories.xml missing from /vendor/otgs/installer.

Go to wp-content\plugins\sitepress-multilingual-cms\vendor\otgs\installer using FTP and from place the repositories.xml file .

repositories.xml file:
=>https://plugins.svn.wordpress.org/woocommerce-multilingual/trunk/vendor/otgs/installer/repositories.xml

Once thats done you need to press "Check for updates"

Let me know if that helped.

June 1, 2017 at 10:26 am #1289259

Michal

Hello Bobby,

you're right. File repositories.xml was missing, because I download beta version of WPML Multilingual CMS by mistake.
I made a manual upgrade to latest version all WPML components and registration has been smoothly completed.

WPML Media 2.1.24 => 2.2.0
WPML Multilingual CMS 3.7.0-beta-2 => 3.7.1
WPML Sticky Links 1.4.0 => 1.4.1
WPML String Translation 2.5.2 => 2.5.4
WPML Translation Management 2.2.7 => 2.3.1

Thank you for help.

You are not logged in. You can view support threads, but not post.
If you are already logged in, please refresh your browser.