This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Registration with Site Key fails? What to do?

Solution:Please go to https://wpml.org/account/sites/ there you should be able to see your site registered (unless u never register your site before)

then click on the little trash icon

and follow the steps shown in the video http://screencast.com/t/nhRozB9TBtBi

Relevant Documentation:

This topic contains 4 replies, has 2 voices.

Last updated by jan-willemv-9 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
July 31, 2019 at 8:41 pm

jan-willemv-9

I am trying to: register my WPML, a site key is asked. Inserting the Site-Key push button, registration fails

Link to a page where the issue can be seen: hidden link

I expected to see: registration successful

Instead, I got: registration failed, see image attached

July 31, 2019 at 9:26 pm #4317699

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Please go to https://wpml.org/account/sites/ there you should be able to see your site registered (unless u never register your site before)

then click on the little trash icon

and follow the steps shown in the video hidden link

let me know your results please

August 1, 2019 at 8:24 am #4319665

jan-willemv-9

Well Bobby, you really have to do better. Of course, I followed instructions on how to perform this. Did you see the attached image? Well, the provide Site Key give this result. IT DOES NOT REGISTER! So that's why I provide WPML with an account and login. Please reflect upon it a moment before you send me a response which is too stupid. I can't believe you are on the support team. I am a first-time use of WPML, but until now I don't think I spend my money well. Hopefully, you can change that. Thank you for solving this problem.

August 1, 2019 at 4:50 pm #4324255

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The steps i provided in the video and listed bellow work as expected, i have test this both times and i was able to register your site as expected.

there is a chance you were copying your URL with the ". " included in the message you get from WPML.

let me know your results please.

1. Go to https://wpml.org/account/sites/

2. Delete your current key and add a new one

3. add the following hidden link

4. copy and paste the key in the registration

August 1, 2019 at 7:58 pm #4324997

jan-willemv-9

My issue is resolved now. Thank you!