This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Related products don't appear on secondary language.

Solution:

Setting the custom field '_wcrp_related_ids' to 'translate' solves the issue.

-On WPML > Settings > Custom Fields Translation, click 'Show system fields' -search for the custom field '_wcrp_related_ids' and set it to 'Translate' -Save. -edit the product. edit it on the original language. -translate the product. You should have the ID field in the WCML editor to add the ID of the translated related product.

This topic contains 7 replies, has 2 voices.

Last updated by Craig 5 months, 2 weeks ago.

Assigned support staff: Dennis.

Author Posts
May 1, 2019 at 8:39 pm

Craig

I have installed this plugin : https://wordpress.org/plugins/woo-custom-related-products/#description on Jupiter theme (Version: 6.1.6) but the related products seen here : hidden link don't show up on the alternate language view : hidden link

I can't seen to find any other control in WPML to make them show up ?

May 2, 2019 at 6:45 am #3722137

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

I noticed the issue on your site. To be able to test why this is happening, please, can I install the Duplicator to make a copy of your site and install it on my test environment? This will help me debug the problem.

Kind regards,
Dennis

May 2, 2019 at 12:22 pm #3724421

Craig

Thank you Dennis. Please do go ahead..

regards

May 3, 2019 at 6:22 am #3731083

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I have successfully created a duplicator package. I will download a copy and try deploy it on my local machine. Then I will continue debugging your site locally and will give you feedback when I got some results.

Kind regards,
Dennis

May 3, 2019 at 8:16 am #3732083

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Could you please try these steps?

-On WPML > Settings > Custom Fields Translation, click 'Show system fields'
-search for the custom field '_wcrp_related_ids' and set it to 'Translate'
-Save.
-edit the product. edit it on the original language.
-translate the product. You should have the ID field in the WCML editor to add the ID of the translated related product.

Does it help? Please let me know how it goes.

Kind regards,
Dennis

May 6, 2019 at 12:26 am #3744131

Craig

Hi Dennis, Sorry I missed your reply. I followed those steps and do see the ID in the WPML translation editor.. but it doesn't show in the front end. Are you seeing the same on your test site ?

thanks

May 6, 2019 at 1:45 am #3744195

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

It could be that you have assigned a wrong product ID for French translation. You should use the french product ID.

For example for 'Coffee Infographic' product the English product ID is 980, while its French product ID is 981.

Hope this helps. Please let me know how it goes.

Kind regards,
Dennis

May 6, 2019 at 3:25 pm #3750355

Craig

My issue is resolved now. Thank you!