This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The alternate links to the translated pages are missing the protocol part (http).

Solution: Go to Dashboard → Settings → General and make sure that the links added to the WordPress Address and Site Address fields have the protocol part.

This topic contains 4 replies, has 2 voices.

Last updated by Pierre Bertrand 1 month, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
August 22, 2019 at 7:04 pm #4442345

Pierre Bertrand

I am trying to:work on SEO

Link to a page where the issue can be seen:hidden link

I expected to see: Absolute url

Instead, I got:Relative

August 23, 2019 at 7:39 am #4444869

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Pierre,

Thank you for reaching out the WPML support!

Can you go to Dashboard → Settings → General and make sure that the links added to the WordPress Address and Site Address fields have the link that you want, please? As far as I know, these are the values used on the elements that you captured on your screenshot. Can you give this a try and tell me it does the trick for you?

Thanks,
Radu

August 25, 2019 at 8:08 pm #4455041

Pierre Bertrand

Hello Radu

So your are saying its not WPML that is stripping the https: from the url. I am getting a red flag error from auditing tools on all my pages for using relative URL instead of absolute and since its this plugin producing the link... I taught that maybe a parameter ??

Thanks
Pierre

August 26, 2019 at 2:11 pm #4459579

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Pierre,

The WPML plugin is not stripping the https part for sure. I attached a screenshot from my website, and this part is added as you can see.

Can you tell me if you checked the fields from the Settings section as I asked you to, please? Also, is this issue still available if you try to deactivate all the plugin except for WPML (and its add-ons), and activate a default theme (like Twenty Nineteen)? There's a chance that some other plugin or even the theme that you're using might be causing this issue. We can find some more about this once you run this little test.

Thanks,
Radu

August 28, 2019 at 7:52 pm #4476727

Pierre Bertrand

My issue is resolved now. Thank you!