Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 3 voices.

Last updated by julianZ-4 1 year, 5 months ago.

Assigned support staff: Alejandro.

Author Posts
June 19, 2020 at 2:57 pm

julianZ-4

Multilanguage custom taxonomy now get rel=canonical tag all pointing to the main language.

June 19, 2020 at 4:06 pm
June 19, 2020 at 4:19 pm #6413787

julianZ-4

Hi Laura

The migration is complete now 🙂 You can do your tests

June 19, 2020 at 4:28 pm #6413821

julianZ-4

Seems that it also somehow removed the language switcher on cloudways.

So it's easier for you, you can test p.e. this site: ..../fr/shops/gonser-fr/ which has canonical to /shops/gonser/

June 20, 2020 at 2:33 pm #6418105

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi,

the problem seems specific with the theme, as I tried reproducing the issue in a Sandbox with Toolset Types, but the canonical hreflang is correct, as you can see here hidden link

I'm trying to reproduce the issue with the theme here hidden link
but I don't understand how to create the custom taxonomy. Can you please give me some indication?

June 20, 2020 at 3:04 pm #6418137

julianZ-4

Hi Laura

You need to go to rehub option -> affiliate options and enable the dealstore taxonomy: hidden link (I did that for you)

Then you go to posts -> affiliate store to create the taxonomy: hidden link

I think after that, you need to enable WPML for dealstore-taxonomy. But I don't want to interfere with your work 🙂

June 20, 2020 at 4:12 pm #6418181

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi,

If I only add and translate the taxonomy like you showed, me I can still see the correct rel=canonical

However, I noticed that if I edited the post, the interface was the classical WordPress one instead of the one I saw in the copy, that resembles a category page.

So I added a custom slug under "Set custom link slug for Affiliate Store. Update permalinks after this in Settings - permalinks"
After doing that, if I try to edit the post I see the same interface I have in the copy, but there are no rel=canonical at all.
See here hidden link

So I can see there is something strange with the theme, but I'm not sure of the process, and I need to be able to explain it to the compatibility team.

June 20, 2020 at 5:07 pm #6418323

julianZ-4

Hi Laura

I think the setup is correct as it is now. The "strange" editor of this taxonomy comes with the theme.

I think you see maybe no canonical because AMP and yoast SEO is not installed on your sandbox?

I tested this and installed free version of yoast plugin on the sandbox. Now it shows canonical again. Interestingly, it is showing the correct canonicals..

BUT then I added this option in WPML: hidden link And now, the canonical is wrong. Still "not as wrong" as on our website: hidden link it is now doing the canonical to the old url-structure. But when you click on the link, you are redirected to the "english" version, instead of the correct "italian" version

Does that help?

June 21, 2020 at 7:49 am #6420065
julianZ-4

Hi Laura

Also, I wanted to ask if you maybe have a fix for the following problem with yoast SEO 13.5. (that's why I upgraded to yoast 14.3. in the first place):

When I noindex a post, the noindex tag is not displayed in the corresponding AMP page. You can check it out in this example:
noindexed post: hidden link
not-noindexed amp page for this post: hidden link
-> I'm not sure if this problem is relating to WPML, because when I disable WPML, the noindex tag is still not there.

=> after upgrading to yoast 14.3. this error is not persistent. But I can not upgrade to 14.3. because of the problems we're discussing in this thread.

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/yoast-no-index/

June 22, 2020 at 2:39 pm #6427343

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

I'll take over this ticket since lara is currently on vacations. i wonder if you could kindly add the workaround from this thread and see if that problem is fixed:

https://wpml.org/errata/search-page-title-in-wordpress-yoast-seo-is-not-translating/

The issue in the errata page is not the same, but we have a few issues that are all related so if this workaround works here, then it might be related to the core issue which we are fixing right now.

Since the new Yoast version came out, a lot of unexpected issues arose and we are trying to "catch them all" to make our plugins as compatible as they were before.

Please let me know so i can understand how to continue.

June 22, 2020 at 3:13 pm #6427751

julianZ-4

The problem seems to be the automated indexing feature from yoast seo, which is not resolved yet: hidden link