This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.66 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have removed Anchor links by turning off the option "Add Row Anchors to URL" in the page builder settings, but this removes anchor id only on the original language.

Solution: Please switch the flag on the top bar and open the AR language version and turn off the option directly on the translated page.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by mohammadA-33 3 weeks, 5 days ago.

Assigned support staff: Marcel.

Author Posts
September 19, 2019 at 12:05 pm #4604519

mohammadA-33

Hello..

I'm using Salient theme and WPbakery, it seems that my website is not Mobile-friendly by google mobile test.

I found that removing anchor links make my website mobile friendly, I have remove it by turning off this option "Add Row Anchors to URL" in the page settings, but this remove anchor id in original language only (English)

I am trying to remove anchor id in translated language (Arabic)

you can see anchor id in Arabic in this link hidden link
here is in English where no anchor ID hidden link

regards..

September 19, 2019 at 3:12 pm #4606731

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mohammad,

Thank you for contacting WPML Support.

Can you please post me a screenshot from the option "Add Row Anchors to URL" ?

Thanks
Best Marcel

September 19, 2019 at 6:49 pm #4607955

mohammadA-33

Thank you Marcel for your reply, it's in the page editing..

regards..

September 20, 2019 at 2:00 pm #4612827

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mohammad,

Thanks for the screenshot.

WPML doesn't set anchor links. The /ar comes because of the active setting "Different languages in directories". An anchor link would be #ar not /ar.

Using this setting WPML doesn't need the "/en" endpoint on your ".com" Domain. An alternative for this option is to use the language parameter "?lang=ar" option to solve this.

More information you will find on https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Best Marcel

September 20, 2019 at 5:53 pm #4613993

mohammadA-33

I'm not talking about /ar I know it is for Arabic language!

the anchors is ar/#180 , ar/#simplify etc..

I managed to remove them in "English" by the button "Add Row Anchors to URL" as I mentioned before.

thank you..

September 23, 2019 at 7:32 am #4621179

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mohammad,

as I don't have access to your Backend anymore, please try to switch the flag on the top bar and open the AR language version and check if you can turn off the option here directly on the page.

Best Marcel

September 23, 2019 at 9:41 am #4622039

mohammadA-33

My issue is resolved now. Thank you Marcel!