This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Image strings (alt text, title, caption, and description) are showing for translation in the ATE.

Solution:

This is expected if the WPML Media add-on is activated. If you don't need to translate media strings, then deactivate thePML Media add-on.

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/media-translation/

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by joepF 2 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 28, 2019 at 3:48 pm #4295623

joepF

Dear support,

We use the Divi and WPML to build a multilingual webshop. To translate pages we use your new translation editor. However, the translation editor also detects (image) file names as strings that have to be translated - which, of course, is not the case.

How can I get rid of said strings?

Kind regards

EDIT: title is not correct. Should be about images, not module names.

July 28, 2019 at 4:06 pm #4295665

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

It seems that you were disconnected from this chat. If you need more help then please reply here. Please make sure that you using the latest version of the Divi theme. And also please correct the following. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

July 28, 2019 at 5:34 pm #4295775

joepF

Thank you. I have set the memory limit now.

July 29, 2019 at 8:43 am #4297875

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

Please let me check things on your site.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

July 29, 2019 at 10:49 am #4298895

joepF

hidden link
--removed by supporter--
Please refer to the English homepage when looking at the translations. Other pages are not finished yet. Thanks for your help!

July 29, 2019 at 4:06 pm #4301763

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm sorry for any inconvenience that might have been caused to you. It might be that I forgot to enable the private message. In the future, please refrain from posting sensitive information in the public forum. For your site's security, please change the credentials and share with me the access details in the private message that I'm enabling now.

Thanks,
Itamar.

July 30, 2019 at 11:23 am #4307151

joepF

Please refer to the private post of "JULY 28, 2019 AT 4:03 PM" 🙂

July 30, 2019 at 5:38 pm #4309877

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thanks, I can access your site now.

The WPML Media add-on was active on your site, and therefore the images alt text, title, caption, and description (which in your case where the same string) were presented for translation. I deactivated the WPML Media, and this issue is now gone. Please see the attached screenshot. I've left it deactivated. If you don't need to translate any media texts or replace an image in the other languages, then keep it deactivated. Please read our documentation about Media Translation here.
https://wpml.org/documentation/getting-started-guide/media-translation/

Regards,
Itamar.

July 31, 2019 at 7:42 am #4312435

joepF

My issue is resolved now. Thank you!