Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.06 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
June 18, 2021 at 7:41 pm #9028477

allen-parkerH

Looking to remove the [English] and [Francais] portions of my SEO titles. I am able to delete the text in Yoast, however when I save, the text reappears.

Very much a beginner, thank you for your help!

Screen Shot 2021-06-18 at 3.38.18 PM.png
June 19, 2021 at 9:21 pm #9031439

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

That's pretty weird.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

June 22, 2021 at 8:51 pm #9049875

allen-parkerH

Hi, any luck? Thank you

June 22, 2021 at 8:53 pm #9049877

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

I'm still in the backend but it seems to me that those pieces of text were added manually there as I don't think our plugin adds that to the SEO title.

I manually removed it from the homepage (hidden link) and saved it and it works fine.

I'm still checking but I think they will need to be removed manually.

If you create a new post test or page test, can you please let me know if those strings are still added automatically to the title Yoast settings?

Please let me know.

Mihai

June 23, 2021 at 5:10 pm #9056977

allen-parkerH

Hi Mihai,

I just created a draft test page and the text still appears. The [English] also appears on the French side of the website as well.

Thank you,

Screen Shot 2021-06-23 at 1.08.18 PM.png
Screen Shot 2021-06-23 at 1.09.27 PM.png
June 25, 2021 at 3:23 pm #9069475

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and thank you for letting me know.

Then it seems that this kind of information is somehow added dynamically.

I will try to dig a little deeper and see if I can find where this is coming from but it will take some more time.

I will get back to you when I have more feedback - I'm leaving the ticket assigned to myself.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Mihai

June 29, 2021 at 10:15 pm #9090951

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and thank you for your amazing patience.

This is a very weird issue taking place on your website and from what I can see, the "[English]" tag can be seen in multiple places from the Yoast settings:

- hidden link
- hidden link
- hidden link
- hidden link

I am also attaching screenshots below.

Also, the issue is that whenever I'm trying to remove that part ("[English]") and click "Save changes", the changes don't save.

So this is either related to some server settings or it is happening due to (at least) one of the active plugins or the theme itself.

Please try this:

IMPORTANT: Please note that a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs (or other similar plugins like "Duplicator").

1. Disable all the plugins except the WPML related ones from your WordPress Dashboard > Plugins and see if the issue is gone (see if you can remove and save that part from Yoast settings) - if the issue disappears, activate one plugin at a time until the culprit one is found.

2. If the issue persists, temporary change to a default WordPress theme such as the 'TwentySeventeen' theme from your WordPress Dashboard > Appearance > Themes menu.

Please let me know how that goes and if following any of these steps solved your issue or brought any change.

I will be waiting for your response.

Mihai

Screenshot 2021-06-30 at 12.59.46 AM.png
Screenshot 2021-06-30 at 12.57.12 AM.png
Screenshot 2021-06-30 at 12.57.06 AM.png
Screenshot 2021-06-30 at 12.56.55 AM.png
Screenshot 2021-06-30 at 12.56.43 AM.png
Screenshot 2021-06-30 at 12.45.02 AM.png