Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 7.27 hours from now. Thank you for your understanding.

This topic contains 13 replies, has 2 voices.

Last updated by Dražen Duvnjak 9 months, 4 weeks ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
November 26, 2021 at 4:02 pm #10075821

Kristof

An SEO audit informed us that there is no /fr/ homepage entry in the sitemap hidden link which surprised us, but indeed, there is a /fr/home/ entry instead.
We just installed the WP Seo plugin as I found in previous support tickets this would fix the issue, but it hasn't. Are there more settings in the WPML plugin that are required?

November 29, 2021 at 7:09 am #10084799

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello!

Welcome to WPML Support. I'll do my best to help you solve this issue.

Yes, that is correct, installing WPML SEO should have fixed the issue:

- https://wpml.org/errata/rankmath-seo-adds-incorrect-entries-for-translated-homepages-in-the-sitemap/

Make sure you have cleared cache, so you are not seeing the old sitemap.

Can you enable/disable the sitemap so it creates a new one and check if the issue still happens when only the WPML plugin and Rankmath are enabled, all others disabled?

Let me know how it goes and if you still have issues.

Thanks,
Drazen

November 29, 2021 at 11:20 am #10086681

Kristof

I have cleared cache multiple times, did not fix it.
Enabled troubleshooting mode with Rank Match, WPML and WPML Seo enabled, did not fix it.

November 29, 2021 at 12:07 pm #10087011

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back and testing.

It could be a new issue happening with the latest versions.

I created a minimal installation of WordPress, WPML, and all necessary WPML add-ons.

You can access the WordPress dashboard using the link below:
- hidden link

Kindly follow the steps below:
- Set up WPML
- Install the necessary plugins.
- Try to replicate the issue.
- Share with me step by step guide on how can I check the issue

This will help us to report the probable issue to the compatibility team and solve the possible problem faster.

Let me know how it goes.

Thanks,
Drazen

November 29, 2021 at 2:06 pm #10088125

Kristof

I can't seem to replicate the issue on your sandbox.
I have created a duplicate of the site and disabled all plugins except WPML, WPML SEO and RM. The issue is still present there. Is there a setting in WPML or WPML SEO that I need to change in order to fix it?

Screenshot_2.jpg
November 29, 2021 at 2:19 pm #10088199

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back and taking the time to try and replicate.

If it is not happening on the sandbox, then is an issue specific to your website/environment.

No there isn't any additional action you need to choose from the WPML side, it should work fine as it is on the sandbox.

In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

You can safely add your information into these fields.

Thanks,
Drazen

November 29, 2021 at 3:01 pm #10088503

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I have checked and it seems the issue was caused since all of your homepages had the same slug. Translating it fixes the issue. Images attached.

I have tried to replicate it on the sandbox, in order to confirm it is a bug and escalate it to our developers, but it seems it works fine there also if the same slug is used.

Please check and if this workaround solution works for you.

Kind regards,
Drazen

Screenshot_6.jpg
Screenshot_5.jpg
November 29, 2021 at 4:24 pm #10089173

Kristof

I have tried your workaround on the live site, changing the slugs of all homepage translations. I then saved permalinks again, the /home-nl/ slug is still present in the sitemap.
hidden link
I can see you fixed it on staging. Anything else I need to do to make the workaround work on live?

November 30, 2021 at 8:13 am #10092573

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I have done and tested a few other things (disable plugins, save permalinks, disable /enable page sitemap and etc) but none of them fixed the issue. The only other thing you can try is to disable Adjust IDs for multilingual functionality from WPML > Languages.

If you still have an issue, maybe you can create a new copy and let me try again step by step to see why it isn't working on your live website.

Let me know how it goes.

Thanks,
Drazen

November 30, 2021 at 8:42 am #10092775

Kristof

Hi Dražen,
Thank you for your patience.
I have just pushed the live once again to the staging. Strangely, the urls in the staging are fine (/de/, /nl/ ...) but on the live they are still /home-de/, /home-nl/ ...
How is this possible? Staging is a copy of live.
Both slugs are set to "home-nl"

Disabling "Adjust IDs for multilingual functionality" did not do anything.

November 30, 2021 at 9:06 am #10093215

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

You need to re-generate sitemap (page sitemap disable/enable) each time you make some changes, probably it is showing the old one in your cache/server cache.

Please try to re-generate, and if you still have an issue, please share access to a website where I can see the issue and it still happens, so I can take a look.

Thanks,
Drazen

November 30, 2021 at 10:35 am #10094339

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

You are seeing an old sitemap, probably the same as why you see it working on a staging website.

You need to go Pages sitemap, disable and save, then enable and save in order to regenerate the latest page sitemap.

I have tried to debug, but it is very difficult, sitemap page loads to me 4-5 minutes and sometimes even crashes without loading, so I can not check it out properly in that condition.

If you wish me to continue debugging on a live website, please provide proper wp-admin login credentials, not temporary and FTP access, so I can safely disable/enable plugins. (Make sure to have a backup)

Otherwise, I can try again checking on staging again, just need new access. It could be also some other plugin is interfering with this or similar, which I can not check properly on the live website.

Let me know,

Thanks,
Drazen

November 30, 2021 at 12:04 pm #10095239

Kristof

Hi,
I just noticed that the navigation in the non default languages was broken on the live site. Did you perhaps uncheck "Adjust IDs for multilingual functionality"? When I checked it, the navigations were fine again.
Also, the issue seems fixed now, I have no clue as to how or why, but hidden link now shows the urls without the /home/

November 30, 2021 at 12:10 pm #10095325

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

yes, I have disabled it, sorry for not enabling it back on. 🙂

Glad to hear it works fine now, could be something else was interfering or cache.

Anyway, since it is working now please monitor and if the issue comes back we can debug it further.

Kind regards,
Drazen