This thread is resolved. Here is a description of the problem and solution.


I am trying to remove the menu switcher from the menu(s), top, header, and footer but it doesn't seem to be working - the language flags still show up.


Increase the WP Memory Limit to them minimum requirements.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by alexanders-10 8 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
September 26, 2019 at 9:25 am #4645069



I am trying to remove the menu switcher from the menu(s), top, header and footer but it doesn't seem to be working - the language flags still show up, EN localisation shows up in the main menu but does nothing once clicked.

I have purposefully disabled it for now since I am having multiple issues with the plugin, but it does not seem to go away.

(1) I have clicked the little trash can icon in the MENU SWITCHER option under WPML > Settings;

(2) I have even deactivated WPML temporarily;

Still no effect. Please help.


September 26, 2019 at 9:47 am #4645369


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Alex.

This ticket has been inactive for quite a while, so I'm transforming this chat into a support ticket because I believe you're still encountering the problem. You'll still be troubleshooting the problem with me and this way we will not lose any progress made so far.

Some themes have the Language Switcher option in there theme options. And it can be enabled and disabled from there. Please check if this is the case that you are having.

If you need more help from me could you please share your Debug information with me?
You can read the detailed explanation about it here.
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.


September 26, 2019 at 10:43 am #4645787


Shalom Itamar!

I have just pasted the debug info.

Many thanks

September 26, 2019 at 4:17 pm #4648827


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

If it doesn't help themn, please share with me the access to your site and explain to me how to see the issue on your site.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:


- - Please make a backup of site files and database before providing us access. --


September 26, 2019 at 8:42 pm #4650269


Many thanks, WP memory increase seems to have helped. Language switcher is teporarilly removed form site until I find another way to go about translating it into English.