This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Mixed translation content after switching to Manual editor from WPML transaltion editor

Solution: Disconnect the translation, update and connecting with the original content solved the issue Refer detaled solution : https://wpml.org/forums/topic/remove-pages-from-translation-editor-manual-translation-required/#post-4195165

This topic contains 10 replies, has 2 voices.

Last updated by Raja Mohammed 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 8, 2019 at 1:41 pm

Cara Mc Donough

I am trying to: remove pages from Translation Editor so I can use the manual translation for all pages and posts.

I am using the X-Theme and Cornerstone builder. Since purchasing X-Theme and WPML, I have manually translated all German pages and posts for our website using Cornerstone, and I have no intention of changing, as I had too many issues with the editor in the past.

Last Friday I had minor changes for our career pages both EN & DE. This is what is currently showing for the DE version: hidden link
Please note: I have had to remove this page from the menu and navigation on the site until this issue is resolved.

I have had lots of correspondence with the X-Theme support over the past 4 days to try and resolve this issue, below their reply on how to fix the issue:

“The issue with the German page is that you used WPML's Translation Editor and that is loaded instead of the Cornerstone built version.
Please contact WPML support to learn how to remove the page from the Translation Editor so the manual translation which the builder uses will work.”

Furthermore, I have uploaded a screenshot which the X-Theme support team forwarded (remove_from_translation_editor.jpg).

If removing from the translation editor solves this problem, then I need to understand how to remove ALL pages and ALL posts, so I don’t encounter the same issue with other pages and posts. I currently have outstanding urgent amendments for other pages and posts for the website.

Also can you please advise if any additional amendments to the “Multilingual Content Setup” settings on the individual pages/posts are required, see attached screenshot “careerPage_MultilingualContentSetup.jpg”

On a side note, is there a possibility of completely deactivating and deleting this plugin? There ties in with an ongoing performance issue I have been encountering for the site. I have attached an overview of all the WPML plugins that I am using. Really appreciate your feedback on this. However, urgency is with resolving the translation issue first.

Appreciate your speedy assistance on this.

Many thanks

July 9, 2019 at 8:42 am #4168701

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

I have understood your issues as
- Remove pages from translation editor
- Enable default WordPress editor for all pages to use cornerstone builder
Correct me if I am wrong.

I would recommend completing any pending translation and mark them 100% complete in the transalation editor before applying the below steps.

Recommended backup your database and site

To remove all the pages from the translation editor

- Goto WPML > Translation Management > Translation Jobs, Click on the 'X' icon to cancel the pages that are already sent for local translation which is using translation editor. You can only cancel the jobs that are in progress

To turn off Translation editor and enabled manual translation for all the pages

- Open the edit screen for a page in the default language, under the Language section turn off the use of WPML translation editor for translation, A popup will prompt you whether to apply for this page for All the pages select All pages or whatever option appropriate for your usage.

“Multilingual Content Setup” settings look fine no further amendment required.

I have attached screenshots for your reference, I hope this helps you better, Please let me know if you need further assistance.

Kind regards
Raja

July 9, 2019 at 2:54 pm #4172049

Cara Mc Donough

Hi Raja,
Many thanks for your reply and in particular, for forwarding the screenshots, which are always great.

Unfortunately, the problem is still there and the German career page is still showing a mixture of English and German content.

First of all, please note: this is the new URL for the German career page: hidden link

A couple of questions to the steps you outlined and also the steps I have taken over the past 5 hours!
1. You said, complete any pending translation and mark them 100 complete in the translation editor…you didn’t provide a screenshot here, so I selected:
WPML->Translations->Page translation: Career
I selected Translation as complete and saved, see attached screenshot.

2. As advised, I checked “Translation Management”, but all Action icons were grayed out, so nothing to select.

3. I turned off the translation editor as advised for ALL pages, selecting “Off” for the WPML translation editor on the Career (English default) page.

The result after above amendments was no different to what I forwarded. Preview in Cornerstone correct, but page online was still showing mixed English and German content for the German career page.

I noticed that the Yoast SEO Multilingual and Yoast SEO Premium plugins were deactivated, so I activated both plugins.

Also, I checked the WPML->String Translation and after over an hour found the correct page builder shortcode strings listed and completed the translation for the first string in the list, which was not showing as completed, see attached screenshot.

I proceeded with clearing all caches, i.e. X-Theme, even WPML navigation cache and of course the browser cache and suddenly the last section on the German page was displayed correctly, i.e. background graphic, text and button element AND the text on the page is aligning correctly! Unfortunately, the problem is still there and the first section with the 2 headlines and the headline in the second section is still showing in English online instead of German.

Seeing there was a common denominator with issues for the headlines, in Section 2: I added new Headline elements and the result was rather shocking, see attached screenshot (test_new_elements.jpg).

The “Classic Headline” element is not showing the German Text, The newer “Headline” is listing the German text, the Text element which I added to use as a headline is not showing at all and the bottom section with background graphic, text and button is completely missing and the container for the alignment is not working.

As a result, this means there is not a problem with the Cornerstone elements. I proceeded with deleting the “Classic Headline” element, “Text” element for the headline and the result is better but still not fixed, you can see the result online: hidden link

Is there a problem with String Translations?

I forwarded my WP login credentials in my previous message, could you please access and have a look and help try fix this issue.

Not only do I urgently need to fix the problem with the career page, but I need to make urgent changes to other pages and I cannot afford to run into the same problems.

Thanks in advance for your swift action and assistance.

July 10, 2019 at 4:55 am #4176097

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks or the detailed and clear information it has more information necessary to fasten the work 🙂

I have checked your site in detail the issue still persists after a few troubleshooting steps, I would like to take a deeper look for that I need a snapshot (copy) of your site to debug the issue on my local environment without disturbing your live site.

This might be a server cache, testing the site on the local environment will give more information.

You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/. I have enabled private fields for you to securely share the details with me.

PS: Sorry that I have missed adding a screenshot for translation completion.

Update:
Before proceeding with duplicator copy, please run a few troubleshooting steps, Secure a backup of your site and database
Goto WPML > Support > Troubleshooting: (check screenshot)
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information
-- Fix post type assignment for translations

Let me know if that helps.

Kind regards
Raja

July 10, 2019 at 7:41 am #4176755

Cara Mc Donough

Hi Raja,
Appreciate your feedback. I completed the troubleshooting steps as advised.
Each step was performed within a couple of seconds. The last step in your list…”Fix post type assignment for translations” triggered a popup, see attached. All too quickly and indeed, the problem is still there after refreshing the Career page (hidden link).

As requested, I installed and activated Duplicator and proceeded with successfully building the package.

Please note: in the past I have NOT been able to install and activate Duplicator. This has to do with the hosting provider we have. There was a change to our hosting contract last year. Although I had success building the package, I am not sure if there will be any problems when you proceed with activating the files

After the “Scan” step was completed it displayed 2 “notices” for “Files – Size Checks” under Archive and Database - Overview, please see attached screenshots.

I selected “Yes” to continue and proceeded with the build. The package was created successfully.

Can you please access and download the installer and archive files directly from WP:
Duplicator->Packages
Package Name: 20190710_managetopia

For obvious reasons, I am extremely reluctant to upload both packages to our server where our website is hosted and it is against company policy to use Dropbox and Google Drive for GDPR reasons.

I think you are correct is saying it might be a server cache issue – I think the “notices” displayed in Duplicator for the File Sizes and Database Size backs up your theory.

If you have any problems accessing the package and installing locally, please advise what I should do. Thanks.

Again, many thanks for your assistance.

Hope to hear back from you today.

July 10, 2019 at 2:50 pm #4181631

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information,

I am able to obtain the duplicator package, I have checked a few options and spent a lot of time debugging the issue, However, this is something that requires a deeper look from a specialist, I have request second tier of supports to take look into the issue. I have shared my results with them. I will keep you posted one I have an update from them.

Kind regards
Raja

July 10, 2019 at 2:55 pm #4181753

Cara Mc Donough

Thanks Raja for your reply and great to know that you were able to access the duplicator page and thanks for trying to debug this issue.

Thanks for escalating the issue and requesting second tier support. I hope we have a result tomorrow?

By all means keep me updated.

Thanks again

July 11, 2019 at 6:41 am #4186373

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am communicating with the second tier with some debug results. I just found the translation is saving content from the English language instead of German, However the same is not happening with a new page.

I will keep you posted with further updates

Kind regards
Raja

July 12, 2019 at 5:10 am #4195165

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience,

I am able to resolve the issue in my local environment, please follow steps:

- Secure a backup of your site and database
- Open the German translation of Career page hidden link
- Under the Language section , Select "--None--" for the option "This is a translation of" (Refer screenshot 1.png)
- Update the page and refresh, make sure you stay on the same page
- Click on Edit with Cornerstone,
- Make some minor changes, save and exit to the dashboard
- Under the Language section , Click "Connect with translation" Choose Career as parent page (Refer screenshot 3.png)
- Update the translation

I hope the steps are clear and easy to follow If you feel you need assistance, Please, let me know.

Kind regards
Raja

July 12, 2019 at 6:43 am #4195557

Cara Mc Donough

Hi Raja,
Indeed this solved the problem. Thanks too for your patience and your ongoing assistance with the problem.

Please can you tell me what the problem was exactly, or what possibly caused the issue?

I need to make outstanding amendments to other pages and plugins need updating, so would be good to know before I proceed.

Would really appreciate your feedback on this.

Thanks a million again

July 12, 2019 at 7:23 am #4195951

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Gald that help you 🙂

The issue happens when the page is translated from page builder (manual translation) and WPML translation editor simultaneous. We highly recommend using any one method and make sure the translation is complete before switching to another translation method.

If you have issues with other pages please follow the same steps as mentioned in my reply
https://wpml.org/forums/topic/remove-pages-from-translation-editor-manual-translation-required/#post-4195165

Have a great day

Kind regards
Raja