Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by davidM-237 1 year, 8 months ago.

Assigned support staff: Max.

Author Posts
August 28, 2020 at 6:03 pm #6895975

davidM-237

Tell us what you are trying to do?
I want to remove the underline in the menu for just the flag

Is there any documentation that you are following?
No

Is there a similar example that we can see?
I don't know

What is the link to your site?
photoantiguawedding.com

Screenshot 2020-08-28 at 12.01.02.png
August 28, 2020 at 8:47 pm #6896639

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. I see that your site is currently under construction. Can you please share login details so I can take a look at your language switcher? I have marked the next reply as private. Thanks!

August 31, 2020 at 2:53 pm #6908453

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm still unable to see the site, I just see the "COMING SOON" message.

September 10, 2020 at 4:02 pm #6986939

davidM-237

You can see the site now. Please could you let me know if there is any CSS code that would enable me to remove the underline on the flag in the menu?

September 10, 2020 at 7:43 pm #6988217

Max
Supporter

Languages: English (English ) French (Français ) Russian (Русский ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello David,

Lauren is away so I'll do my best to answer your question, hope that's all right with you.

The site is available now, thank you. I see that the underline only shows when the mouse is over the flag icon. If I understood correctly, that's what you'd like to remove.

This CSS snippet should provide a right direction. It's just a starting point - you'd need to insert it into the theme CSS stylesheet and possibly adapt it further.

.wpml-ls-item:hover .elementor-item:after {
    background-color: transparent !important;
}

Info on how to include custom CSS with your theme: hidden link

September 10, 2020 at 7:55 pm #6988259

davidM-237

Thanks for your reply!

I have added this to the WPML plugin. Is that correct? Please see the attached screen shot.

I have designed the website with elementor and the Hello theme. If the code you gave me is not in the right place can you give me an idea of where I need to add it?

David

Screenshot 2020-09-10 at 13.52.37.png
September 10, 2020 at 8:12 pm #6988349

Max
Supporter

Languages: English (English ) French (Français ) Russian (Русский ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Yes this is good: I looked at the site and it appears to be working. Here's an improved CSS snippet to also hide the transition effect:

.wpml-ls-item:hover .elementor-item:after {
    background-color: transparent !important;
    -webkit-transition: none !important;
    -moz-transition: none !important;
    -o-transition: none !important;
    transition: none !important;
}
September 10, 2020 at 10:48 pm #6988873

davidM-237

Hi!

I added the code but the flicker is still there sadly.

Here is a screenshot. Any ideas?

David

Screenshot 2020-09-10 at 16.46.39.png
September 10, 2020 at 11:33 pm #6988929

Max
Supporter

Languages: English (English ) French (Français ) Russian (Русский ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

You can try removing the transition on the item itself as well as its hover state. Updated snippet:

.wpml-ls-item .elementor-item:after,
.wpml-ls-item:hover .elementor-item:after {
    background-color: transparent !important;
    -webkit-transition: none !important;
    -moz-transition: none !important;
    -o-transition: none !important;
    transition: none !important;
}
September 10, 2020 at 11:40 pm #6988965

davidM-237

My issue is resolved now. Thank you for being so prompt. Nice one!