This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Mihai Apetrei 1 month, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 7, 2020 at 2:00 pm #5858131

erikaM-5

How can I remove the language switcher from the secondary menu? The switcher makes it impossible to use the site's menu when viewed on mobile.

I have tried disabling all non-WPML plugins. It didn't work.
I have also tried switching to a default WP theme. It still didn't work.

April 7, 2020 at 2:30 pm #5858355

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

If you are referring to the language switcher in the "hamburger" menu (I attached a screenshot below), you can remove that by using the following custom CSS code that you can add inside "Appearance > Customize > Custom CSS":

ul#av-burger-menu-ul .wpml-ls-menu-item {
    display: none !important;
}

Please let me know if that solved your issue 🙂

Kind regards,
Mihai Apetrei

April 7, 2020 at 2:46 pm #5858449

erikaM-5

Hi Mihai.

No. I mean the flags after where it says "Call us now (305) 501-0133" all the way at the top. People can't access the hamburger menu because of this.

April 7, 2020 at 3:38 pm #5858783

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Oh, ok.

Thank you for letting me know.

It seems that that language switcher is added by the theme itself (I can see that by the CSS class that is being used in the code).

A quick way to hide it generally on the site is by using this custom CSS code:

.avia_wpml_language_switch_extra {
    display: none !important;
}

If you would like to hide it only on mobile devices, you can use a CSS code like this:

@media screen and (max-width:600px) {.avia_wpml_language_switch_extra {
    display: none !important;
}}

That should solve it 🙂

Kind regards,
Mihai

April 7, 2020 at 5:19 pm #5859827

erikaM-5

My issue is resolved now. Thank you!

April 7, 2020 at 10:54 pm #5861203

erikaM-5

Hi. Sorry, I just noticed that after I added this code to my site the Spanish version of my homepage got disconnected somehow from the English version of. Please see video of my screen where I demonstrate the problem.
hidden link

April 8, 2020 at 3:03 pm #5867227

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

The code that I gave you is strictly related to the layout/styling on the front-end section of the site - it can't affect anything in the database.

From what I can see, if I go to the Spanish version of the homepage, I get a "Page not found" error which means that something is wrong in the backend.

I can take a look for you to see if I am able to fix it quickly but if I won't be able, I will need you to please open a new ticket as we are allowed to handle one issue per ticket.

But maybe I can get things back working for you 🙂

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 9, 2020 at 3:00 pm #5877261

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

From what I can see (please check the credentials), there's no home page selected here so I'm not sure how is the website set up.

Can you please let me know from where did you set in the settings of the backend of the site which one is the front page?

Please let me know.

Kind regards,
Mihai

April 9, 2020 at 6:47 pm #5878921

erikaM-5

The homepage is called "Effective Therapy and Psychological Testing". So I went in and set the frontpage on the Spanish version of my theme. And it looks like it's working again. Can you please confirm this? The only problem I see that is some of the translation on the Spanish page reverted back to English. But that's easy fix.

April 10, 2020 at 10:20 am #5883139

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there.

Thank you for the confirmation.

I just checked now and things work as expected so I think that was the issue.

Kind regards and please stay safe,
Mihai