Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Mihai Apetrei 6 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
January 9, 2020 at 6:28 pm #5264297

Martin Petersen

Hi,

I have big issues with menu sync on kj-klimateknik.dk. I have decided to disable menu sync and instead build menus manually.

I have made a site to test (so I dont mess up live-site) and deleted all menues to reset menu sync.
Then I have tried to build a few menus manually in danish and Russian. With different menu items, to make sure it's possible.

But now I get same Danish menu on the danish version as the russian version.
Danish menu: hidden link

Russian menu: hidden link

At the same time, the home page have a lot of menu items, that don't exist in the WP menu manager. hidden link

Please help.
Best regards,

Martin

January 10, 2020 at 3:24 pm #5269815

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

In order to accomplish what you explained, I think that you would need to start from scratch.

I know you already tried that, as you mentioned, but we need to make sure that after you create the default-language menu, when you create the translation of the menu, instead of using the sync functionality, you just create them manually, like it is mentioned here: https://wpml.org/documentation/getting-started-guide/translating-menus/#option-1-translating-menus-manually

If you already tried that and it doesn't work, I would like to get access to the back-end panel of the testing environment that you created.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

January 13, 2020 at 12:32 pm #5282455

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for access.

From what I can see here (hidden link), you are running on very very old versions of our plugins, old versions of other plugins, old version of WordPress and old version of themes.

Running plugins that are so old and not updated are mostly the main reason why you are encountering that issue.

Can you please update everything to the latest version and then remove the menus and follow the same steps from the beginning and see if the issue is still happening?

Please let me know how that goes.

Kind regards,
Mihai