This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 17 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 14, 2018 at 2:06 pm #2121602

mikeX

Hi, I have switched themes from Divi to Beaver Builder and noticed that all the translation fields for the Divi builder elements are still showing in WPML's translation editor.

I have re-created all the pages, so there are now Beaver Builder's modules being used. I have gone through and copied all previously translated content to the new fields in the translation editor.

Is there a way to remove them all now?

Thanks

Mike

May 15, 2018 at 5:40 pm #2145693

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- Go to WPML -> Support -> Troubleshooting link -> Click on the 'Clear the cache in WPML' button.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

May 17, 2018 at 12:25 am #2165866

mikeX

Hey Carlos, I went through the steps and the old Divi page builder fields are still there in the translation editor.

I've included the debug information, hopefully, it will shed some light.

Thanks!

Mike

May 17, 2018 at 4:29 pm #2179773

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,
Thank you very much for your feedback.

Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Does the issue persists?

Kind regards,
Carlos

May 17, 2018 at 7:33 pm #2181626

mikeX

Yes it does

I still have for example: "et_pb_text: content" along with "Info Box: Title Prefix".

First one from Divi, second from Beaver Builder, both displaying the same information.

Seems like all the Divi fields were left behind in WPML when Divi was deleted.

Any other ideas?

thx

May 17, 2018 at 7:44 pm #2181879

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Best regards,
Carlos

May 21, 2018 at 5:10 pm #2203119

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,

Thank you very much for sharing this information.

I would like to ask your authrorization to make a copy of the site in order to make further tests on a local environment without affecting the live site.

Looking forward to your answer.
Regards,
Carlos

May 21, 2018 at 5:48 pm #2203500

mikeX

No problem Carlos, go right ahead 🙂

May 21, 2018 at 8:04 pm #2204090

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,

Thank you very much for your authorization.

However, it seems that the user you created doesn't have administrator role. Could you set the wpml user to administator? This way I will be able to make the cooy of the site.

Regards,
Carlos

May 21, 2018 at 9:19 pm #2204384

mikeX

ah WPML was set to admin but needed to be authorized under the plugin WPShapere... it is now 🙂

May 22, 2018 at 3:44 pm #2209899

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,

I was able to reproduce the issue on a local environment. I have escalated this ticket to our 2nd tier of support. Our specialists in the 2nd tier will take a deeper look at this issue and they will try to isolate it's cause.

I will get back to you as soon as I get an answer from them.

Thank you very much for your patience and understanding!
Best regards,
Carlos

May 22, 2018 at 4:24 pm #2210430

mikeX

No worries, thanks for digging in!

May 22, 2018 at 5:15 pm #2210780

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,

Than you veyr much for your understanding!

I will get back to you as soon as I get an answer from our specialists in the 2nd tier of support.
Best regards,
Carlos

May 30, 2018 at 3:40 pm #2252171

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Mike,

The cause of the issue is thata WPML is loading the strings that are registered as a package for that page. The home page is with ID 72

So in WPML > Packages, there is an entry:
Page Builder ShortCode Strings - Page Builder Page 72
If you cancel that page - the strings will be deleted from the String Translation page and the package will be deleted as well. Thus no more Divi strings will be displayed in the translation editor anymore.

Note: Please be careful as there is another entry for Beaver Builder with ID 72 - and if you remove that package - you will remove the current page builder strings that are used - and that is something that you don't want.

Having said all that, we don't think that we want to remove the strings automatically, so this "workaround" should be the proper procedure on how to do it.

Please don't forget to create a full backup of the site before making any change, for security reasons.

Let me know if you need further assistance.
Best regards,
Carlos

May 30, 2018 at 8:48 pm #2253392

mikeX

ok, that makes some sense. I tried to remove the page builder package for the home page with ID72 on a local site.

When I go to the translation management page for the home page now, I get a long list of errors: Warning: Invalid argument supplied for foreach() in /app/public/wp-includes/class-wp-list-util.php on line 163

Screenshot: hidden link

...and then a list of package string fields: hidden link

Below all that I have the Beaver Builder fields still in place.

Is there something I need to do after removing the package? Is that the only place I need to do something?

thx