This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 6, 2018 at 4:04 pm #2290262

davidR-88

Hi,

This is in regards to the the ticket "Issue with Language Switcher on french site only" We are comfortable sharing the codebase and other necessary details.

Please provide us with private field to upload the codebase and other details.

June 7, 2018 at 10:00 pm #2398208

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I have set your next answer private, there you will find the correspondent fields for the credentials requested.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Looking forward to your answer.
Kind regards,
Carlos

June 15, 2018 at 1:58 pm #2415754

davidR-88

Further to my private comment. Pantheon Supports two mode of file update on dev.
1. Git : This mode will not allow any user to change files directly on the server.
2. SFTP : This mode will not allow any user to push there change via GIT.

Out team is working on the website. Could you please let us know the timing when you need the SFTP access we can make them available at those hours, until they we would like to have the GIT mode on the server.

June 15, 2018 at 4:27 pm #2416040

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I need to ask you to update all outdated plugins, themes and core to their lates version. Outdated functionalities can cause conflicts on the code.

Once the step above is done then I kindly ask you to visit this link where you will find a tutorial on how to set different domains per languages using WPML: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Best regards,
Carlos

June 18, 2018 at 6:49 pm #2420168

davidR-88

ok let me update the plugins, themes do not close this issue i will update you once done.

June 18, 2018 at 10:54 pm #2420431

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I will be waiting for your message.

Best regards,
Carlos

June 21, 2018 at 5:08 pm #2427879

davidR-88

I have update the plugins and wordpress itself to its latest stable release.

Seems like the issue is still not resolved.

June 21, 2018 at 8:53 pm #2428230

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

It seems that the cause of the issue is the configuration in WPML -> Languages -> Language URL format where you set the same domain for both languages.

If you select any of the other options, save the changes and re-save the permalink structure, does the issue persists?

Best regards,
Carlos

June 25, 2018 at 4:29 am #2431687

davidR-88

Hi,

I tried everything form my side. i have provide you with the site access. Please check from your end and try to fix it. it's been so long i am facing this issue and need to resolve ASAP.

June 25, 2018 at 6:17 pm #2433558

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I went to WPML -> Languages -> Language URL format -> Selected 'Different languages in directories' option -> Saved the changes -> Re-saved the permalink structure and the site seems to be working correctly.

Could you confirm that the issue is solved?

Best regards,
Carlos

June 26, 2018 at 12:22 pm #2435167

davidR-88

its working but not as expected. its now adding language as suffix what is need is Language per domain.
hidden link
hidden link

June 26, 2018 at 5:34 pm #2436018

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Your default language is ENglish, which means that the domain for this language is hidden link

First you need to change your default language or your domain to match the correct language and then change the option in WPML -> Languages -> Language URL format

The end result must be:
1.- First alternative: Leave English as default language and change the domain of the site to hidden link
OR
2.- Change the default language of the site to French and then add the URL hidden link in WPML -> Languages

Please let me know if you need further assistance.
Best regards,
Carlos

June 27, 2018 at 12:55 pm #2438522

davidR-88

I am aware of the WPML settings.

I am having default language as English and the url is hidden link
and on WPML Language URL format I am setting the url for french
i.e hidden link

This works fine as long as i am on english website

But when you go to any french page for eg :
hidden link
The language switcher is not showing correctly ( for english it is showing french url)

June 27, 2018 at 10:19 pm #2439769

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi David,

I just saw two issues on the site:
1.- If I log in the English site and go to WPML -> Languages -> Language URL format -> If I click the 'Save' button I will get a 'Not valid' message. This means that the configuration of the domains is not correct or this is a false positive, in this case I kindly ask you to visit the following link where you will find the steps to correctly setup the domains: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

2.- If you log in the French page and go to WPML -> Languages -> Language URL format -> Both domains are the same (see attached image). This is not correct.

Please follow the steps in the link provided above and double check that the domains are set up correctly.

Best regards,
Carlos