This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by louis-philippeD 3 months, 1 week ago.

Assigned support staff: Lauren.

Author Posts
June 10, 2019 at 7:08 pm

louis-philippeD

HI, I have many problems using this version of WPML with my CPT & Fields built on toolset and types.

1)
I have a custom post type called "project".
In this CPT, I setup fields and one of them is a repeater group. I set both to be translatable
I can translate only one of the subfield, the second one does'nt even show in the translator management.
Field ROLE : OK
Field NOM : not showing in translation
hidden link

1B ) Also in the same CPT, i setup an images field (Photos) and I created a slider with it. At first it works but I did lose the copied images from "Copy from original to translation", now there is the same number of images but they are all the same 🙁

2) Under AWARDS
hidden link
I translate all the content but it still stays in french on the front-end. I also miss one of my item.
Again, I'm using a Repeater Group with some fields in it. Those subfield are available to be translate and are complete.

What is the link to your site?
I hide the english version for now...

June 10, 2019 at 7:27 pm
June 10, 2019 at 7:27 pm #3989881

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

June 10, 2019 at 7:50 pm
June 12, 2019 at 3:08 pm #4005595

louis-philippeD

I haven't had any feedback for a couple of days. Is the support still looking? Thank you

June 12, 2019 at 3:45 pm #4005881

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for your patience. I set up a fresh install to try and reproduce the issue but I was not able to replicate with a default theme and only WPML/Toolset plugins. Please feel free to play around on the staging site to see if you are able to find something that maybe I missed:
Login: hidden link
Username: demo
Password: c63ArNXB88mk

I also set up a copy of your site locally. I deactivated all non WPML/Toolset plugins and switched to a default theme. I then updated the post in the original language and added content for all of the custom fields. After these steps, all of the fields display in the translation editor. However, with these settings, I was not able to view the content on the front end.

Is this something you would be able to test on your live site? If so, please temporarily switch to a default theme and deactivate plugins and then let me know if the fields appear in the translation editor after updating the original project.

June 20, 2019 at 7:57 pm #4062881

louis-philippeD

Hi, sorry for the delay.
I clone my site to a test site and the problem was persistent. So i just erased all WPML content to do a reset and now, from scratch, even the elementor template did not copy themselves on the new pages. 🙁

Original : hidden link
English :hidden link

It seems that i'm back to square one.

June 21, 2019 at 3:16 pm #4067991

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

The pages that you sent me look the same in both languages on your test site. Can you double check the URL? Is there another page where the layout is not being copied over?

June 21, 2019 at 3:46 pm #4068187

louis-philippeD

I currently found out that I needed to go back to the classic editor for that to work!
Now i'm completing the main pages and translation and I convert some repeater field to normal posts so the translation works fine now.

Please stand by for the first inquiery, i'll test that again in a moment.

1)
I have a custom post type called "project".
In this CPT, I setup fields and one of them is a repeater group. I set both to be translatable
I can translate only one of the subfield, the second one does'nt even show in the translator management.
Field ROLE : OK
Field NOM : not showing in translation

June 21, 2019 at 5:25 pm #4068757

louis-philippeD

My issue is resolved now. Thank you!

It's still a non working issue that may needs to be address by the dev team of WPML and TOOLSET.
The use of a repeater field does'nt work as intended for translation!

How do I make it works in the end ?

a) make my CPT to Translatable - only show translated items
b) go to support --> troubleshooting
c) click on empty WPML cache...

Thank you for your help!

June 21, 2019 at 5:40 pm #4068773

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

When I go to edit a Project, I see the message attached in the screenshot. If you change this setting, does it resolve the issue?

June 21, 2019 at 8:18 pm #4069093

louis-philippeD

Not at all.
See the credits in those pages :
hidden link
hidden link

And I even change this settings back and forth, empty all caches ( browser ), went back to troubleshooting. Nothing changed.

June 24, 2019 at 4:57 pm #4078831

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I updated the original page, and then was able to see the fields in the translation editor. When I marked the translation as 100% complete, the translations display correctly for me:
hidden link

June 25, 2019 at 3:08 pm #4085819

louis-philippeD

First, I really thank you for all you hard work!
So if I understand right, I just have to go back to the original language and save the page again ?

June 25, 2019 at 4:32 pm #4086203

louis-philippeD

Also, do you see your test page or it is just a blank page ? Maybe you did something that i don't know of...