This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 24, 2018 at 12:52 pm

frankd-21

I am trying to: replace sections with others

Link to a page where the issue can be seen: blueplanet-it.net/home

I expected to see: the new sections also appear in translated pages

Instead, I got: the original sections (ones i deleted) in the secondary languages. Also, for some reason, the language menu disappeared. Its such a mess...

September 24, 2018 at 6:08 pm #2761515

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @frankd-21,

I noticed that you are using Elementor. Are you using a page template for the header or for these elements? If yes, please check if they are translated on Elementor > My Templates.

I also noticed that you are using the Manual Editor. In this mode, if you add/remove a element from the original page, you need to manually update each translation as well. Please check if using the "Classic Editor" mode solves this issue. You can do this test on some page:
IMPORTANT: Please backup your site first before making any change, this is important for security reasons.
- Go to WPML > Settings > How to translate posts and pages, set it to "Use the Classic Translation Editor" and save
- Go to pages > All pages and change to
- Change the language using the Language Switcher at the top admin bar
- Backup the translation if needed, then delete the translated page
- Go to "Trash" and delete the translation from the trash as well
- Go back to "Pages > All Pages" and change back to the original language (using the Language Switcher at the top admin bar)
- Create a new translation for the page
- Fill all fields, check all "Translation is complete" fields and save

Please let me know if the translation work ok on this mode.

I also checked the settings of your server through debug log and saw that some items need attention:
MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please let me know if it worked for you.

All the best,
Diego

September 28, 2018 at 10:15 am #2773214

frankd-21

Hi, i will try all your tips today and let you know if its resolved, thanks Diego!

September 28, 2018 at 2:18 pm #2774204

frankd-21

does this mean every time i change something, i need to delete all translations and start again from scratch? Thats soooooo much wasted work, as it is right now! Not only are all the changes i made to the original pages (in english) gone somehow, but all the other pages need to be translated again??? Is there a way to download all the translations so at least i can copy paste? But seriously, dont tell me every time i change a part of the original site, i need to delete all translated pages? If thats the case, you can put me in a mental hospital...

September 28, 2018 at 5:56 pm #2774564

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Frank,

Sorry fo that, my mistake. I just mixed the solution with the solution for another similar ticket that I was working. The steps are simpler:
- Go to WPML > Settings > How to translate posts and pages, set it to "Use the Classic Translation Editor" and save
- Go to to the edit screen of the page (original language)
- Change the language using the Language Switcher at the top admin bar
- Edit with Elementor and check if the elements are correct on the back-end. If not, fix it.
- Save
- Check if the changes are applied to the translation

If you follow these steps, it fixes the issue? If not just let me know, I will take a look.

Kind regards,
Diego

October 2, 2018 at 9:09 am #2780772

frankd-21

I havent found the time yet to try the second part. Have replaced all the sections that were lost, next ill try the translations...

October 2, 2018 at 7:08 pm #2782558

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Ok, please let me know if it worked or if you need more help.

Regards,
Diego