Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 38 replies, has 2 voices.

Last updated by Lauren 1 month, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
September 20, 2017 at 4:18 pm #1378172

ricardoA-9

Hi,

First of all, I'm sorry I didn't get back to you sooner. In the mean time to "solve" the issue, I deactivated WPML and all related plugins, however some weeks ago, I was pressured to add a new language to the website, so I didn't have a choice and, here I am, with the lowest Performance score of any of my websites after activating WPML again.

Because the website is already online, I created an exact copy (hidden link) to perform all the actions you guys asked me to, and what I found out was:

The actual cause of my performance score deacreasing a total of 50% while using WPML is the related plugin "Advanced Custom Fields Multilingual ". Am I required to use it for WPML to function properly? It triples my website requests, page size and by consequence the loading time as well 🙁

And now to answer the several questions Bobby asked me in my first thread:

Q: If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps were followed?
A: Already have.

Q: Confirm the following settings are OFF or Disabled in WPML: Auto ID adjust state; Track where strings appear; Auto register strings.
A: Disabling "Auto ID adjust state" helped a bit, my website went from scoring a 0 to a 5% on GTmetrix -_- ... I think I don't have the other two enabled.

Q: What type of hosting do you have? Shared, VPS, Dedicated, etc?
A: My website is on a VPS;

Q: Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.
A: My website is running on PHP 7, and the opcache extension is selected, is that what you meant?

Q: Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?
A: Yes.

Q: Make sure Disk caching is disabled.
A: I'm using Redis, is that better?

Q: Try disabling the W3 total cache plugin.
A: It only gets worse;

What am I to do? I can't let my website with such a bad performance.
Please, help me with this, I'm all ears for what you guys have to suggest.

Thnaks in advance,

Carina.

September 21, 2017 at 1:40 pm #1379212

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this. Please make sure WordPress Core and all plugins and themes are using the latest version.

You only need to use Advanced Custom Fields Multilingual if you are creating fields with Advanced Custom Fields plugin. Are you using that?

Please try deactivating the WPML plugins and then activate them one at a time, starting with WPML core, then Translation Management, String Translation, and then any others. Do you notice if there is a difference in performance after these are activated?

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

September 28, 2017 at 6:07 pm #1386627

ricardoA-9

Hi,

WPML keeps on doubling my website html requests, page size and loading time. I need help fixing this, please! it's just unbearable to open a website that takes more than 20s to load.

I've been trying to optimize it as much as possible, deativated most of my plugins, but even if I keep just Slider Revolution and Modern Events Calendar, the page load gets out of proportion once I activate wpml!

Here's my website (it's a clone of the original):

url: hidden link

How can I send you my credentials?

Please, have a look and help me solve this :/

Thank you!

September 28, 2017 at 6:11 pm #1386629

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 28, 2017 at 7:53 pm #1386676

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. When I deactivate all plugins accept WPML, the site loads very quickly for me.

I noticed that you are using an older version of WPML and we have had a lot of performance updates in the latest releases. Please update all WPML plugins to their latest release. Then reactivate plugins one at a time to see if there is a conflict with another plugin that could be causing the slow performance.

I also see that you have many plugins installed but more than half are deactivated and many are not up to date. I would recommend deleting any unused or unnecessary plugins. If you need to keep them installed, make sure they are up to date even if they are deactivated.

Another thing I notice is that if you click on Pages, the languages show a count of pages but none show up in the list. To resolve this, please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting. Look for 'Clean up' and click the following:

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information

Lastly, please set my user status to Admin. I need to test your site with a default theme and I don't have access to many of the admin menu items, such as Appearance, Settings, and even WPML does not show up in the admin menu.

September 28, 2017 at 9:03 pm #1386725

ricardoA-9

Hi Lauren, thank you so much for your fast reply!

I thought I'd already set your user to admin, but somehow it was set as editor, I'm sorry, I already fixed it. I've also updated WPML to the latest version! I usually have all my plugins up to date, two of them need some minor edits before I update, but the website was already loading very slowly before the updates were available.

Most plugins were deactivated because I was testing, but once the loading time got to absurd extents, I stopped activating them.

Please do whatever you need, to improve my website performance regarding WPML.

Thanks!

Carina

September 29, 2017 at 2:59 pm #1387415

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sharing the additional information. I installed the query monitor so that I could collect some data on my tests.

I deactivated all plugins except WPML and switched to a default theme, and load time was around 3 seconds. I then activated all plugins one at a time and found that when I activated The Grid plugin, the load time jumped up to almost 9 seconds. I then reactivated the Javo theme and the results were the same. (attached screenshots are with Javo theme activated).

So then I reran these tests with WPML core deactivated and The Grid deactivated and again, the load time was around 3 seconds. When I reactivate WPML core, load time jumps up to about 9 seconds.

Lastly, I deactivated all plugins accept WPML plugins and the Grid, and load time is still around 6 seconds. So it seems there is a compatibility issue between The Grid and WPML. I don't see them on our compatibility list here: https://wpml.org/documentation/plugins-compatibility/

Is there anyway you could send me a copy of The Grid plugin so that I can test this on a clean install? If I am able to reproduce, I can forward to our compatibility team and they can get in touch with the plugin author to try and find a resolution. You can upload the file to Google Drive or Dropbox and paste the link in your next reply. I have marked it as private so that only you and I will have access to it.

Screen Shot 2017-09-29 at 10.38.38 AM.png
Screen Shot 2017-09-29 at 10.39.57 AM.png
October 2, 2017 at 2:32 pm #1389061

ricardoA-9

Hi Lauren,

Did you get the link with the plugin you asked me?

Is there any development on this issue?

Thanks again!

October 2, 2017 at 2:46 pm #1389095

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the plugin file. I was not able to reproduce the slow load time once I installed the Grid plugin. Would it be possible for you to create a duplicator snapshot so I can test a copy of your site locally? That will help me eliminate any server issue and run some further tests.

If that is okay with you, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it!

October 2, 2017 at 3:36 pm #1389161

ricardoA-9

Oh, that's too bad.

I'm trying to make a duplicator package right now, but it looks like it will be way too big, even if I exclude the paths you mentioned - also, it's taking way too long.

Aren't you able to do so? You're certainly more used to this and know exactly what to exclude in the compressing process...

Thanks again!

October 2, 2017 at 4:53 pm #1389228

ricardoA-9

Hi again,

Just checking if you're actually trying to create a package, because my I/O and Physical Memory usage is through the roof. And I'm guessing/hoping it's because of that.

Thanks you!

October 2, 2017 at 10:01 pm #1389385

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Ricardo, I was not attempting to make the package. If it is okay with you, I can install Duplicator Pro and try the duplicator package with that version. Let me know if that is okay and I will try first thing when I start my day tomorrow.

October 3, 2017 at 8:17 am #1389655

ricardoA-9

Hi Lauren,

Please do so! I'd be very greatful. Please let me know once you start.

Carina

October 3, 2017 at 1:08 pm #1390118

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Carina, just a note to let you know that I am going to install the Duplicator Pro plugin and attempt a snapshot of your site. I'll let you know if I am able to download everything.

October 3, 2017 at 1:13 pm #1390129

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I tried to install Duplicator Pro but I get the following message:
The uploaded file exceeds the upload_max_filesize directive in php.ini.

I also attempted to install the plugin via FTP but the FTP credentials provided are not allowing me to connect. Could you please contact your hosting provider and ask them to increase the upload_max_filesize? The plugin file is around 4MB.

Let me know when this has been changed and I will proceed with the duplicator package. Thanks!