Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 5 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 2, 2020 at 1:55 pm #5599719

sebastianK-50

Hello WPML support,

When we update our front page in the WP Backend the whole Website gets a Request timeout error.
This didn't happen until recently.
We realized the error has something to do with the WPML Multilingual CMS Plugin, because if we deactivate the Plugin we can Update our Pages just fine.

The Website is a Multisite and it happens on all Multisite that have this plugin active.
Our max_execution_time is currently 300.

Is this a known problem and/or is there a solution for it?
Thanks in advance.

March 3, 2020 at 1:37 am #5603395

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 4, 2020 at 7:17 pm #5619965

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. It seems something server specific instead of something common to WPML as we don't further reports of timeout issues as a rule for our customers. In your case chances are any other third party plugin or theme code is interacting with WPML and causing this issue, as a detailed test, please try the following:

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

1 - Rename your current .htaccess file and upload an .htaccess file of a fresh multisite installation, I see some extra rules added by third party plugins that could be the reason for these issues.

2 - Disanle all the plugins and keep only the WPML related ones activated, then try to reproduce the issue activating one plugin at a time untill the possible culprit one is found.

3 - If the issue persits, temporary change to a default WordPress theme and try to reproduce the issue again.

Please, let me know the results, have a nice day.

March 6, 2020 at 3:52 pm #5636615

sebastianK-50

Hello,

sorry but none of this helped

1 - didn't change anything

2 - I've deactivated every plugin but the WPML ones and the timeout error still occurred

3 - I tried the newest enfold version and twenty nineteen but it also didn't change anything.

The problem is still is as long as sitepress-multilingual-cms is active we can't update our front page.

March 6, 2020 at 4:43 pm #5636845

sebastianK-50

Correction:
2 - I've deactivated every plugin except for the WPML ones and the timeout error still occurred

March 6, 2020 at 8:05 pm #5637483

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Before we migrate your website for a test server in order to proceed with a detailed investigation, can you please confirm if the issue persist if you increase your current memory limit to 512M? You can paste the two lines of code below in your wp-config.php to achieve it:

define('WP_MEMORY_LIMIT', '512M');
define('WP_MAX_MEMORY_LIMIT', '512M');

Please, let me know the results, have a nice day.

March 9, 2020 at 4:26 pm #5649019

sebastianK-50

Hello,

I've added both lines of code too my wp-config.php file and the error still happens.

March 9, 2020 at 8:11 pm #5649965

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when the migration is done. Thanks.

March 11, 2020 at 4:14 pm #5665137

sebastianK-50

Hello,

the migration is now completed.

March 12, 2020 at 7:41 pm #5675451

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look at the migrated website and noticed the user with the ID 1 from the wp_users database table doesn't seem to have super admin priveleges and it makes my investigation process harder as I am not able to see the WordPress Dashboard > Plugins section either in one of the subsites or in the multiste administration. It seems you have modified your multisite installation to restrict access to the plugins menu, can you please, provide me with the instructions on how to access it?

It will help me to tweak plugins activation/deactivation to reproduce the issue and find a solution, otherwise I would need to make it via FTP which is very time consuming and would delay the whole process. Please, let me know, have a nice day.

March 13, 2020 at 9:36 am #5678713

sebastianK-50

Hello,

I can create a new temporary login with network super admin privileges.
But right now I can't log into the backend because of the broken reCAPTCHA, could you disable the reCAPTCHA Plugin with FTP, so I can log in again, then I can create a new user for you.

March 13, 2020 at 1:43 pm #5680517

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I disabled the 'Avanced NoCaptcha ReCaptcha' plugin. Please, let me know if you need anything else, have a nice day.

March 17, 2020 at 10:42 am #5700397

sebastianK-50

Hello,

I can't seem to log in with my super admin user.
The user works on innovation-expo.com, but not here on the migrated website.
Is it possible that the users weren't included in the migration process.

An alternative could be to create a new admin user via Database
or to do the migration process again and I create a new super admin user beforehand

March 17, 2020 at 7:17 pm #5704479

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case I think a duplicator package of your website is the better approach here as it will give me more control on users, installed plugins, themes and etc in order to debug your issue. For that, please consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

March 26, 2020 at 6:27 pm #5772955

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and your patience while waited for a solution. I've made some tests and noticed this particular page is corrupted in the database and this is why the WordPress database queries are unable to update the page. The most simple and effective solution I tested was the following:

1 - Install and activate this plugin: https://wordpress.org/plugins/duplicate-page/

2 - Click to list all your pages in the default language from your WordPress Dashboard > Pages

3 - Hover the mouse in the page name and click the 'Duplicate This' link, then you can edit the newly duplicated page and delete the problematic one.

Note: Although you can also duplicate the page translation and the connect the translation to the default language page, I really recommend to add a new translation to avoid any issue.

Please, let me know if it works for you, have a nice day.