This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by Jamal 5 months, 1 week ago.

Assigned support staff: Jamal.

Author Posts
May 1, 2019 at 10:45 am #3717675

murtazaK-2

wpml plugin is not validating our domains. plz login to resolve the issue

May 1, 2019 at 12:09 pm #3717849

murtazaK-2

PLZ JAMAL, WE HAVE DONE EVERYTHING AS IT WAS ADVICED BY WPML, VALIDATION ISSUE STILL NOT RESOLVED, PLEASE ALLOW ME TO GIVE YOU ACCESS TO MY BACKEND TO SEE RESOLVE THIS ISSUE.

May 1, 2019 at 12:23 pm #3717989

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Murtaza,

We are sorry that none have answered you on the Chat, most of the supporters are celebrating Labor Day.

I activated the private box to share credentials.
Can you please paste your WPML Debug information in the Debug information field?
- http://wpml.org/faq/provide-debug-information-faster-support/

If it is not too much to ask, please mark the other tickets as resolved.

Best regards,
Jamal
WPML Support

May 1, 2019 at 1:39 pm #3718331

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I am sorry to tell you that there is nothing we can do. Some hosting software configuration is not set correctly. When WPML try to validate the domain names, he sends a request to each domain and expects to get a reply with a specific string in the beginning. It appears that all domains return an empty folder. Which I can evaluate as each domain is pointing to its own folder. See the attached image.

If the DNS configuration is well done, and the hosting web server has no issue, the 4 requests should be handled by your WordPress installation and return another response rather than an empty folder.

Please reach out to your hosting provider with these details and ask him for help.

I'll remain at your disposal.

Best regards,
Jamal
WPML Support

May 1, 2019 at 1:46 pm #3718411

murtazaK-2

SO, JAMAL, THESE FOLDERS SHOULD HAVE WHAT>?? WHAT SPECIFIC THING SHOULD ASK MY HOSTING COMPANY TO DO ON SERVER FOR THIS VALIDATION???
I see. So there's nothing on shared.
This domain/websites in your cloud server:
- tpcrealestates.de
- tpcrealestates.ru,
- tpcrealestates.se
-tpcrealestates.net

Is empty, they have no files on them. Only tpcrealestates.com has files, Toygun.

Are those 4 domains supposed to have website/files?11:25The screenshot you sent me simply shows the content of your tpcrealestates.de domain. It is empty and has only one directory in it(cgi-bin)

THIS IS THE MESSAGE I GOT THIS MORNING, PLEASE READ THIS MESSAGE AND ADVICE ME ACCORDINGLY. THANK YOU. PLZ ADVICE WHAT THEY SPECIFICALLY NEED TO DO FOR EACH DOMAIN TO REPLY WITH THAT STRING YOU MENTIONED.

May 1, 2019 at 2:02 pm #3718499

murtazaK-2

ONE OF YOUR COLLEAGUE advised ME THIS TOO, YOUR CONCLUSION IS , THOSE DOMAINS ARE NOT POINTING TO WP FOLDER, THEY POINTING THERE OWN FOLDERS WHICH ARE EMPTY??? ALL THOSE DOMAIN WHICH ARE POINTING TO THERE OWN NAME FOLDERS, THEY SHOULD POINT TO WP INSTALLATION????

May 1, 2019 at 2:15 pm #3718521

murtazaK-2

THANK YOU JAMAL I WILL GET BACK TO THEM

May 1, 2019 at 2:33 pm #3718579

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

You are welcome, I'll be awaiting your reply.

Best regards,
Jamal

May 2, 2019 at 11:13 am #3724027

murtazaK-2

hello jamal, after you told me , i asked hostgator to do it on server, validation is gone, now, everthing is in .com, we can not see our translation

May 2, 2019 at 11:15 am #3724031

murtazaK-2

the issue having is , no translation is shown if we click on german or Swedish flag, it revert to .dom domain

May 2, 2019 at 11:30 am #3724129

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I think that the DNS configuration is OK, but the web server configuration is not OK or there is still something to do. Visit, for example, these URLs. At least they should return the same result
- hidden link
- hidden link

I believe that the HTTP server setup is not configured as described in our article. Please ping Hostgator again about it. It seems that they are still handling requests to secondary domains as if they were hosted alone and not as if they point to the primary domain.

See section "Setting up your HTTP server" of our article.
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Best regards,
Jamal

May 2, 2019 at 12:06 pm #3724327

murtazaK-2

jamal, they are saying these changes are not possible to do, i just do not understand , what is the so complicated in this whole matter, i send them everything, you sent me. they have read, its hostgator big company. please advice me what shall i do?

May 2, 2019 at 12:07 pm #3724335

murtazaK-2

We tried every possibilities as well contacted the higher support. The concern you have can be assisted by a web developer on your side, but not from our side. We have exceeded all of our resources and couldn't find a way to point your alias configuration to the wp folder you wanted.

May 2, 2019 at 12:38 pm #3724583

murtazaK-2

jamal this is the screenshot of my channel

May 2, 2019 at 12:57 pm #3724649

murtazaK-2

if i put redirect to .com, main website flags go to main tpcrealestates.com

The topic ‘[Closed] required assitance from wpml’ is closed to new replies.