This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: when you insert your mail to reset the password in the secondary language, the same page shows again instead of sending the mail for resetting the password

Solution: the siteURL and homeURL are different, one is in http: and the other in https: this can cause issue, fix them in Settings -> General and be sure they are identical

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by patrickO-2 1 year ago.

Assigned support staff: Laura.

Author Posts
October 12, 2018 at 6:33 pm #2812933

patrickO-2

I am trying to:
Reset password from the Japanese page of our bilingual site (Eng/Jap)

Link to a page where the issue can be seen:
hidden link

I expected to see:
reset the password

Instead, I got:
when I click the in from the email i am asked to input my email again (for English it works fine)

October 15, 2018 at 1:52 pm #2817858

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

from you debug information I see the siteURL and homeURL are different, one is in http: and the other in https: Sometimes this can cause issue, try to fix them in Settings -> General

If this doesn't work, could you explain me how did you create the reset page? Is the default WordPress form just made prettier or did you use some kind of plugin? In both cases, we need to do a compatibility test:
- backup your site
- disable all plugin except WPML and its addons
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

Of course, if you used a plugin you shouldn't deactivate that one either.

Please let me know the results of this test.

October 15, 2018 at 2:28 pm #2817946

patrickO-2

My issue is resolved now. Thank you very much!