Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 3 voices.

Last updated by Mohamed Sayed 1 year, 2 months ago.

Assigned support staff: Mohamed Sayed.

Author Posts
July 15, 2021 at 11:43 am #9208923

Fabio Fava

Hey Mohamed, I'll have to push some updates from the Live to the Staging site, I'd need a couple hours more, please. Thanks!

July 15, 2021 at 12:17 pm #9209121

Fabio Fava

Hey Mohamed, I've have to pushed some updates from the Live to the Staging site, you can jump in the site is all yours! Thank you very much and sorry for the disturbance!

July 15, 2021 at 4:43 pm #9211237

Mohamed Sayed

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Fabio,

The languages can't be changed for those terms because it's translated so you need first to delete the Portuguese translation then edit the term in the default language and change the language from there.

But those categories can't be deleted as it's the default category and WordPress is not allowing deleting it.

❌So please make sure you have a full backup and try this:❌

Product Categories:

1- Go to Products > Categories

2- Switch the language in the top admin bar to Portuguese, see here please: hidden link

3- Make another category the default one by hovering over it then clicking "Make default", please see here: hidden link

4- Delete the "Sem Categoria" in the Portuguese language

5- Switch back to the Spanish in the top admin bar, then edit the Spanish category and change the language from the language section, please see here: hidden link

6- The final step is to make the "Uncategorized" category as default in all languages again

Post Categories:

Please follow the same steps in Posts > Categories

Translation Priorities:

1- Edit any post then click the "edit terms" link from the Language section in the sidebar, please see here: hidden link

2- Switch to Portuguese from the top admin bar and delete all the Translation priorities in this language. hidden link

3- Switch again to the default language of the translation priorities which is English in your site and edit each of them then change the language from the language section hidden link
(You need to edit the name and the slug of each priority to make it in Portuguese)

after changing the language of all terms, please make sure to re-add the missing translations

Let me know please if that works for you.

July 15, 2021 at 6:11 pm #9211809

Fabio Fava

Thank you Mohamed,

I've managed to reset the Product Categories and Translation Priorities on the Main site, but not the regular Post Categories as there's no "Make default" option for Post Categories. Am I missing something?

July 15, 2021 at 7:05 pm #9211951

Fabio Fava

One detail, even after having succesfully set the Product Categories screen, I still have the alert sign ⚠️ present on that screen. I've done all steps on the Support -> Troubleshooting and cleard all server, wp and browser caches.

I've managed to reset the Post Categories, seems to be all good there, but WPML still does a bit of confusion on the original vs. translations. Would be possible to completely remove WPML also all translations and strings from my DataBase? Then a clean install after cleaning the DB?

I see many old translations and strings there, and the string my web designer has created to the shopping cart isn't working. He created some custom translation and attached that to the cart but I can't remember exactly how he did it. Hope you can help me on that too, thanks!

July 16, 2021 at 2:21 pm #9217887

Mohamed Sayed

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Fabio,

1- To change the default post categories, you need to do that from WP dashboard > Settings > Writing > Default Post Category, then you can set another category as default and follow the same steps by deleting the Portuguese category then change the language of the default language one to Portuguese.

2- The alert sign means that some terms are not translated yet and the screenshot you shared shows none of it is translated, so please translate all and the sign should be removed.

3- To reset WPML, please make sure that you have a full database and website backup then follow the instructions mentioned here:

4- If some strings are added with custom code, they can be translated in the String Translation page. So please go there and search for the strings then edit the translation.

Let me know please if this helps.


July 16, 2021 at 8:45 pm #9219363
Fabio Fava

Hey Mohamed, thanks for getting back!

1 - Done it and it's all good, thanks!

2 - All good there, too, thanks!

3 - Will that remove all traces of WPML from the DB? Where will go the translated contents, post categories, woocommerce categories, etcetera? Will they be moved to the main language?

4 - The question is, I cannot remember what was that custom string, there are so many thousands of strings... That is for the NavBar Cart Icon (on the top-right on the site), but despite having items in the cart, it shows nothing... Any clue on that?

Thank you again for your amazing help Mohamed, I hope we can fix this last thing (4).

Can I delete the Staging site? It does consume server resources, so if it's not needed I'd like to remove it. In case it's needed later, it's pretty fast to recreate it from the Main site.

New threads created by Mohamed Sayed and linked to this one are listed below:

July 18, 2021 at 1:46 am #9223131

Mohamed Sayed

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Fabio,

1- The 'Reset' action will deactivate the WPML plugin after it deletes the translations and language information also the WPML tables (tables with the 'icl_' prefix) from the database. So please make sure to have a full backup first before using that option because it can't be undone.

2- Thanks for confirming that all of the terms have been changed to the right language. I'm marking this one as resolved as the initial issue is already fixed, and will create a new one where we can continue investigating the custom string issue.

Thanks for your cooperation.