Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: REST API is disabled, blocking some features of WPML

Solution: - Disabled the WPML plugins - Enabled it again. - Dismissed the message

Relevant Documentation: https://wpml.org/errata/rest-api-is-disabled-blocking-some-features-of-wpml-notice-and-performance-issues/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Fulvio Di Stefano 1 year, 7 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
December 9, 2019 at 9:49 am

Fulvio Di Stefano

J'utilise wpml sur ce site et il y a un avertissement que je recois dans le dashboard. Vous la verrez sur l'image ci joint.
Cela bloque certaines fonctionnalités de wpml donc je veux savoir comment le resoudre !
Merci.

avertissement.PNG
December 9, 2019 at 11:29 am
December 9, 2019 at 2:02 pm #5093301

Fulvio Di Stefano

Hi,
I have done as you said but it seems things are not going as expected.
On this page for example : hidden link

1- The wpml select languages options on top doesn't show.
2- Attributes on that page are in english and there is no possibility to switch from EN/FR.

Something is not going well.

December 10, 2019 at 2:43 am #5096653

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

We will discuss the rest api issue here, can you please open new ticket or chat for your new issues as it will help us to discuss and fix theme quickly with making them easy to search in future for other users.

Regarding the rest api issue, did disabling all plugins showed the rest api enabled? or is the results showing similar.

Look forward to your reply.

Thanks

December 10, 2019 at 7:24 am #5097273

Fulvio Di Stefano

Hi,
I think it is the same issue. Because REST API desable may be related to the two points i mentionned i mentionned. So i suggest we should treat them here in this ticket.

I have done as you did but i can see it is still desable. The url hidden link doesn't start by the website name as it is explained in the link you sent(hidden link)

What are we doing next ?

December 10, 2019 at 7:48 am #5097297

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you once disable the WPML plugins and check the results of the

<em><u>hidden link</u></em>

Also, can you contact your host and ask if they have restricted rest api to the site?

Look forward to your reply.

Thanks

December 10, 2019 at 3:45 pm #5101305

Fulvio Di Stefano

Hi,
I have contacted my host and they let me know that they haven't restricted REST API by their side.
I try to check everything but still have the same response when i go here : hidden link.

Actually i think it is the REST API disable that causes the two issues i mentionned before so i suggest we try to fix those two issues. When they are fixed, even if the REST API is still disabled, no problem. What is important now is that.

In case you forgot here the two issues are :

On this page for example : hidden link

1- The wpml select languages options on top doesn't show.
2- Attributes on that page are in english and there is no possibility to switch from EN/FR.

Thank you.

December 11, 2019 at 12:52 am #5103615

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, can you please provide me feedback to disable/enable theme on your site? I would need this permissions to debug the issue further.

If possible please create a test/staging site and provide the info to me, so I can debug it further.

Look forward to your reply.

Thanks

December 11, 2019 at 7:49 am
December 11, 2019 at 8:51 am #5104535

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I followed the below steps on the staging site and the issue is fixed:

For rest api issue:
- Disabled the WPML plugins
- Enabled it again.
- Dismissed the message

For attributes issue:
The attributes can be translated from WooCommerce->WooCommerce Multilingual->Attributes section. https://wpml.org/documentation/related-projects/woocommerce-multilingual/#translating-product-categories-tags-attributes-and-custom-taxonomies

Let me know if this helps.

Thanks

December 11, 2019 at 9:10 am #5104753

Fulvio Di Stefano

Hi,
Thank you so much.

December 11, 2019 at 9:11 am #5104759

Fulvio Di Stefano

My issue is resolved now. Thank you!