This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by giacomoG-5 3 weeks, 6 days ago.

Assigned support staff: Bigul.

Author Posts
September 17, 2019 at 11:31 am #4588031

giacomoG-5

I am trying to: View my site

Link to a page where the issue can be seen:

I expected to see: My Site

Instead, I got: Internal Error

September 18, 2019 at 6:23 am #4592693

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please let me know the following for tracking the issue.

a) Please deactivate WPML for a moment on the site and make sure the bug is existing or not.

b) Are you getting the internal server error in the backend and frontend of the site when WPML is active

c) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

September 19, 2019 at 11:12 am #4604117

giacomoG-5

Hi,

I can't view the debug log.
I did all your procedure but there is no debug log. Here you can find the debug of wpml.
Thank you

https://pastebin.com/J7nB7h4S

September 19, 2019 at 11:35 am #4604309

giacomoG-5

Another information:
the problem affects only the frontend, the backend works correctly.

I noticed this string in WPML menu:

cegli il formato dell'URL per la visualizzazione dei contenuti in una lingua
Directory con lingue diverse ((hidden link - Italiano, hidden link - Inglese))
Usa la directory per la lingua predefinita

Cosa mostrare nell'url della root:

File HTML – inserisci il percorso assoluto o relativo alla cartella di installazione di WordPress
Una pagina
Sembra che la creazione di directory diverse per ogni lingua non funzionerà. Dettagli

Questo può essere il risultato di entrambi:

WordPress è installato in una directory (non principale) e tu stai utilizzando i link predefiniti.
Il tuo server web non è abilitato alla riscrittura degli URL.
Il server web non è in grado di scrivere nel file .htaccess
Come risolvere il problema
Quando WPML accede a hidden link ottiene:
codice HTTP: 500 (Internal Server Error)

Il valore previsto è:
<!--hidden link;

September 19, 2019 at 6:00 pm #4607795

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Have you changed the server recently?

Please try the following steps and check you are getting the expected result or not.

1) Visit WPML>>Languages
2) Scroll down to *Language URL format* section
3) Choose *Language name added as a parameter* option
4) Save the changes
5) Go to Settings>>Permalinks
6) Save the settings(just resave)

--
Thanks!

Bigul

September 23, 2019 at 6:44 am #4620723

giacomoG-5

My issue is resolved now. Thank you!