This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Alejandro 4 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
May 25, 2019 at 9:23 pm #3890135

zeyadY

I am trying to:connect result page for english with result page of arabic

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see: the same result that i found at english page

Instead, I got: all property at Arabic page

May 27, 2019 at 9:55 am #3895505

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

First of all, i couldn't check either of the pages because a 500 error was thrown when i tried to access it.

I can see, however that you're not meeting WPML's minimum requirement so Let's start by doing that:

Please add the following code in your wp-config.php file, right after the database information lines of code:

define('WP_MEMORY_LIMIT','128M');

- If that doesn't work, then make sure the products that you want to show in both languages are correctly (and 100%) translated.

- If you have already translated them, then we could be seeing a compatibility issue (as i see, WPML is not officially compatible with this theme and i couldn't find mention of Multilanguage compatibility from the theme's documentation) and for this case, i suggest you upload the theme to this sandbox site: hidden link

Then, try to recreate the problem in there and let me know how it goes.

May 27, 2019 at 8:04 pm #3900719

zeyadY

i am using plugin called " filter & search " as i dont using the main filter of the theme , i added the code that u sent but there is no thing happen i changed the site domain so u couldnt login i need a privet chat to send u the new user name and password

May 28, 2019 at 4:53 pm #3908961

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I enabled the private fields for the credentials. kindly point me out to where that search plugin you sent me is configured so i can check it out because it does sound like a compaibility issue.

Even better yet and just to speed up things a little bit, could you upload the plugin into this sandbox? : hidden link

Then try to replicate the problem, and if you manage to replicate the problem, then we're most likely talking about a compatibility issue.

Let me know when you do.

May 28, 2019 at 8:22 pm #3909993

zeyadY

i added the plugin that i am using it called search & filter Pro so please i need solve my issue as soon as possible

May 29, 2019 at 5:08 pm #3917667

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I see the plugin has instructions to integrate with WPML: hidden link

Please follow them and let me know how it goes (i did so in the sandbox site and it seems to work correctly)

Regards.