This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.59 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by Henry Chandra 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 10, 2019 at 6:24 am

Henry Chandra

I am trying to: open the product reviews in France language

Link to a page where the issue can be seen: hidden link

I expected to see: list of product reviews like other working languages for its reviews

Instead, I got: a not found page

See the attached image for the result i did not expect after clicking reviews for language France.

Previously did a consult with Raja and he told me he changed the Categories settings back to fallback and i did it. It was working on the same day i changed the settings. The next day the issue is still there. Its really weird.

July 10, 2019 at 8:07 am #4177091

Henry Chandra

Could you please have a look at it and tell me what else could be wrong after i fixed the Categories to fallback settings? i tried to change back to previous settings as well but it did not work.

July 10, 2019 at 8:21 am #4177263

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will check this in some time, I am working on a few other issues. I will get back to this issue soon.

Kind regards

July 10, 2019 at 8:36 am #4177347

Henry Chandra

Thank you Raja! Will be looking forwrd

July 10, 2019 at 3:07 pm #4181995

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience,

In my previous instruction, I have requested to revert translation priority for the categories "Translateable - Show only translated content".

Check if there is any server side cache enabled for your site. Your hosting provider can help you in this case, If enabled try clearing the cache, check if the issue persists.

Could you please give me some information is there any pattern that you have identified that lead to disappearing of the Review in the translation? Or it happened all of a sudden?

PS: I am unable to access the site with the supplied credentials, I have deleted the local copy of your site it would be better if you can provide working credentials in order to take a better look into your issue.

Kind regards
Raja

July 11, 2019 at 1:51 am
July 11, 2019 at 8:39 am #4187467

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm Afraid, the updated credential is also not working as expected.

If the issue is happening all of a sudden then it is more like related to cache. Could you please confirm whether there is any server cache enabled for your site?

Once I get access I can check this on my local site with a fresh copy of your site.

Kind regards
Raja

July 11, 2019 at 9:38 am
July 11, 2019 at 2:08 pm #4190687

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience,

The issue happens when the category prefix in URL is removed using Yoast.
To confirm the issue temporarily retaining the Category prefix in URL. to enable the option

Goto SEO > Search Appearance > Taxonomies,
- Select "keep" to retain the Categories prefix in the URL

Check the review page this would work fine throughout the language.

This a known issue and it was fixed in WPML version 4.2.5
https://wpml.org/errata/yoast-seo-strip-the-category-base-does-not-work-in-the-second-language/

Please update Yoast to the latest version check if the issue can be reproduced by removing Category prefix.

If the issue persists after the Yoast update, it needs to be isolated in a fresh installation

Please let me know the results.

Kind regards
Raja

July 12, 2019 at 2:18 am #4194099

Henry Chandra

My issue is resolved now. Thank you!