This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Henry Chandra 3 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 4, 2019 at 7:13 am #4140623

Henry Chandra

I am trying to: open the product reviews in France language

Link to a page where the issue can be seen: hidden link

I expected to see: list of product reviews like other working languages for its reviews

Instead, I got: a not found page

See the attached image for the result i did not expect after clicking reviews for language France

July 4, 2019 at 11:07 am #4142571

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Kind regards
Raja

July 8, 2019 at 6:18 am #4159279

Henry Chandra

I am waiting your reply. Please assist

July 8, 2019 at 7:13 am #4159405

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am afraid, I don't have full access to your site, Can you please provide administrative access to your site. so that I can check for a few parameters including the WPML settings.

Kind regards
Raja

July 8, 2019 at 7:43 am #4159595

Henry Chandra

As of now my manager isnt here and i need his help for the access grant. Let me know how cn i help you and i ll provide the information you needed

July 8, 2019 at 8:46 am #4160165

Henry Chandra

Hi Raja,

Ive granted you the admin access. Kindly get check our system again and let me know yeah

July 8, 2019 at 11:29 am #4161885

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

This seems like a cache issue, I have changed the Categories translation preference to Fallback settings and changed it back to Translatable everything seems to work fine.

Please check if the issue resolved for you as well. Let me know if you still need further assistance.

Kind regards
Raja

July 9, 2019 at 1:40 am #4166433

Henry Chandra

Hi Raja,

When you were checking our issues, is our configurations correct so far? Is there anything to do with the plugins update issue?

July 9, 2019 at 1:59 am #4166527

Henry Chandra

And one more thing , can you tell me the steps how you changed the Categories Translations to fallback settings with more descriptive?

July 9, 2019 at 3:30 am #4167147

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

The translation priority for the categories can be changed from
WPML > Settings > Taxonomy translation, (refer screenshot)

There are 3 translation options

1) Translatable - only show translated items: Once set this will display only the translated items if there is no translation available the page will return 404 error

2) Translatable - use translation if available or fallback to default language : This will display translation if available if there is no translation then the content from the default language will be displayed

3) Not translatable - Content created only in the default language

I think everything looks good and you should not have any further issue, If there is anything else feel free to write to us anytime we will be happy to help you.

Kind regards
Raja

July 9, 2019 at 3:54 am #4167407

Henry Chandra

I need to do this step for different server with the same issue. I got it solved. Thanks Raja 🙂

July 9, 2019 at 3:56 am #4167409

Henry Chandra

My issue is resolved now. Thank you!

July 10, 2019 at 4:10 am #4175929

Henry Chandra

Hi Raja,

Unfortunately i still encounter the same problem today. Yesterday i did change the Categories to fallback and it works. But today when i checked again, the reviews revert back to previous issue where its showing page not found for france and spanish