Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by fulvioP 1 year, 5 months ago.

Assigned support staff: Bruno.

Author Posts
June 5, 2018 at 12:44 pm #2275132

fulvioP

I am trying to have the right strings translated in the right language.

Link to a page where the issue can be seen: hidden link

I expected to see: all the 3 thumbnails right tranlasted like the backend

Instead, I got only 1/2 thumbnail in the right language.

June 6, 2018 at 10:45 pm #2321925

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

Did you translate and publish the three slides? It looks like the default language has a slider unless because either it was not created or it is not published. In the backend, by accessing the slide page, are the three slides created?

Also, is your server using any caching system? If yes, please could you clean it to see if the slide will be displayed correctly?

Thank you.

June 7, 2018 at 6:53 am #2380122

fulvioP

Hi,
yes we publish and translate all the three thumbnails but wpml mixed all!
I don't have any cache on my server.
Let me know.
Thank you

June 7, 2018 at 9:20 pm #2398162

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

June 9, 2018 at 2:30 am #2401491

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. I'm going to test your website and soon I'll contact you.

Thank you.

June 11, 2018 at 7:20 am #2404377

fulvioP

good morning,
any news ?
Thnk you

June 12, 2018 at 12:36 am #2406723

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. I'm still testing your site. I'll contact you soon.

Thank you.

June 12, 2018 at 2:15 pm #2408527

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

It looks like some slides were not created in some languages.

For example, when I click on the second slide, "CUSTOMER SERVICE", note that the Italian flag is not being displayed. This means that the slide in Italian was not created. I'll attach an image for you to see.

Also, make sure also that before editing the slider, you are selected the desired language. When a slide is selected, you may be editing the "All Languages" option. You must be sure to edit the language you want. I'll attach an image for you to see.

About the title of the slides, where they are appearing inside the thumbnail, how are you translating this into some languages? Have you checked if the title is correct in both languages?

Thank you.

June 14, 2018 at 9:26 am #2413009

fulvioP

I've update the italian, but as you can see in attachment in english and es the errors persist.
Please check it.
Thank you

June 14, 2018 at 9:49 am #2413078

fulvioP

As you can see in the back end for ES language, the flag is selected but the titles of the slides come back in Italian.. check it please

June 15, 2018 at 12:28 am #2414545

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

You should simply edit the title and save the changes. This will not be displayed translated in the backend.

- Select the slide language
- Click to edit the title in the desired language
- Click the green button to save changes

The value that will be saved in the backend is the last value used. On the front end, however, this will be displayed correctly according to the language that was selected in the backend.

That is, just select the desired slider and the desired language. Then add the slide title and click the green button to save the changes. Follow the same steps for the other languages. Make sure you are editing the language you want.

Please, could you test and verify if this will work with the other slides you want?

Thank you.

June 15, 2018 at 6:50 am #2414851

fulvioP

Sorry but not work!
I translate ES again and is not ok as you can see.
In Italian the first thumbnail title change to ES!
Check it please.

Otherwise tell me where I can disable the thumbnails because I can't leave an error like this online.

Regards

June 15, 2018 at 1:45 pm #2415704

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

You should be sure to be editing the correct title in the chosen language. If you change the language but keep the title in another language, the title will be displayed incorrectly.

As I explained above, the title in the backend will be the last changed title. So, after you change the language you should edit the title in the thumbnail to the correct language.

I fixed the string "Progettazione" in Italian and it is now being displayed correctly. I'll attach the image with the steps I'm following. You should follow these steps for each of the titles you want to change.

To remove the thumbnails you must edit the slider configuration. Click to edit the slider configuration and then select the "Navigation" option. Change to the "Thumbs" tab and disable it. You can see more in the Slider Revolution documentation: hidden link

Thank you.

June 15, 2018 at 2:06 pm #2415768

fulvioP

I understand and follow what you say me before, but as you can see you adjust the Italian but now the ES is wrong again but in the past was ok.
Check the attachment.. thank you

June 15, 2018 at 3:36 pm #2415958

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Looking at the slider, this does not seem to be translated either - the contents of the slide nor the label. What should be the label of slider and thumbnail so I try to edit it?

Thank you.