Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by George Botsev 5 years, 1 month ago.

Assigned support staff: George Botsev.

Author Posts
October 9, 2014 at 1:37 pm #489236

jin woo

I am trying to: make multi language links

We are creating a theme and having a problem with "my page" part.

We are creating my page pages (like buddypress profile pages) without creating each pages on back-end. therefore we use " add_rewrite_rule and template_include hooks".

ex)
hidden link hidden link hidden link hidden link hidden link hidden link

However WPML is not working on another languages.
ex) japanese
hidden link

404 page when you visit this page. when I change language switch, it goes to home page.

We have changed to "create a my page page" first (when you active our theme, it automatically creates a page is called "my page". it's like buddypress) and get templates on the page.

Then we get templates from permalink. used "wp_query" and "pagename" to get templates.

add_filter('template_include', function(){

	switch( sub-page-value )
		case 'slug value'  //<===== to get template url
			return "template url"
});

add_filter('query_vars', function(){
	return sub-page-another-value; //<===== this is for get variable for slug
});

add_action('init', function(){
	add_rewrite_rule( '^member/([^/]*)/?$', 'index.php?pagename=member&user=$matches[1]', 'top');
	add_rewrite_rule( '^member/([^/]*)/([^/]*)/?$', 'index.php?pagename=member&user=$matches[1]&sub=matches[2]', 'top');
});

url type is hidden link / member / {username} / {sub page name}

The original language works fine. however on another page it doesn't get any variable ( get_query_var) and it goes to home page.

Please assist us. we have been spending time for it more than 20 days.

I believe that you have our temporary account information. and ftp information on previous ticket which was closed.

Best regards,
Rob

October 10, 2014 at 11:20 am #489840

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

It seems you need custom programming work which is beyond the scope of our support.
At this point I would suggest you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/

You will get the custom assistance you need to get on with your project.
Before doing so please have a look also here: http://wpml.org/documentation/support/wpml-contractors/guidelines-for-people-looking-for-consulting-help/

October 11, 2014 at 9:00 am #490353

jin woo

yes solved rewrite issue. however, I have minor issues related with this.

1. Language URL format is not working. only working ( Different languages in directories )
2. on my page (front-end), the switch goes to home only.

Thank you again

October 13, 2014 at 6:31 am #490763

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Can you please elaborate a little more?
If you want to use the option "A different domain per language" you can check our FAQ here: http://wpml.org/faq/server-setting-for-languages-in-different-domains/
If you have some problems with "Language name added as a parameter", this could be a problem with your rewrite setup also or maybe a known bug like this described in our errata page: http://wpml.org/errata/language-as-parameter-loses-language-information-when-displaying-search-results/

About the language switcher, do you use a custom one or the stock one?
If you use the custom one you could check here: http://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/ and verify that you are using it correctly.

The topic ‘[Closed] Rewrite rule member llink’ is closed to new replies.