This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Laura 2 weeks ago.

Assigned support staff: Laura.

Author Posts
August 22, 2019 at 2:43 pm

stephanieK-9

I am trying to: menu English text on English pages (Microwidgets) fall back to English, even if set to English

Link to a page where the issue can be seen: my webpage in menu

I expected to see: English texts

Instead, I got: German mixed

August 22, 2019 at 4:07 pm
August 22, 2019 at 4:43 pm #4441647

stephanieK-9

Migration done

August 22, 2019 at 5:59 pm #4442029

stephanieK-9

I could change everything, only this is left. I don't know if my changes will be permanent.

Left over:

German Page:

1. "CONTACT" must be "KONTAKT"
2. German Section

Copyright Webseite Design & Medien: Jakob Voges 2019<br><a href="mailto:mail@voges-design.com"><a href="<em><u>hidden link</u></em>"><font size="small">DSGVO</font></b></a> | <a href="<em><u>hidden link</u></em>">AGB</a> | <a href="<em><u>hidden link</u></em>">Impressum</a>
August 23, 2019 at 4:05 pm #4448635

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I checked the copy and there the copyright text is correct in both languages: hidden link

So I think this might be an issue with your hosting. Could you try to disable any caching plugin that might exists and also check if you have server caching enabled and if it's possible to disable it?

About the button, I'm not sure from where it comes. Didn't you find it in String Translation?

August 26, 2019 at 6:14 am #4456121

stephanieK-9

Hi

thank you I will re-check server caching

- copyright text bottom I deleted string (it was set to german with English translation) and added new. (english version with German translation) - now it is German (let's see how long)
- for the button click here on Microwidgets under "Theme Options"

hidden link
"BUTTON 1"

String Translation:

admin_texts_the7dtchild
[the7dtchild]header-elements-contact-multipurpose_1-caption

EN:
<a href="hidden link">CONTACT US</a>

DE:
<a href="hidden link">NACHRICHT SENDEN</a>

Just search for "contact" and you will find it

- The button on your test server is in English... in German version there should be "KONTAKT" or "NACHRICHT SENDEN"

August 28, 2019 at 10:06 am #4473007

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

sorry for the delay in replying. I did some tests, but I don't understand why the string is not translating so I need a second opinion on this. I'll let you know as soon as possible.

August 28, 2019 at 4:49 pm #4476067

stephanieK-9

Hi Laura

Thank you so much for further help. I will wait until you write again. Thank you

Maybe have a look into wpml xml ...
jakob

August 29, 2019 at 2:16 pm #4481705

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Jakob,

the microwidget [the7dtchild]header-elements-contact-multipurpose_1-caption is not the one which creates the button - the right one should be

[the7dtchild][header-elements-button-1-name]

BUT even if I can see it in the string admin page and I added it in the xml-config, I can't find it in String Translation. I'm not sure what the problem is here.

August 30, 2019 at 10:35 am #4486441

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the issue is now escalated to the 2nd tier, I'll let you have news as soon as possible.

September 2, 2019 at 9:17 am #4495643

stephanieK-9

Thank you for update. I will
Wait until there is a solution 🙂

September 3, 2019 at 2:54 pm #4505615

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we deleted and re-registered the strings and now everything should be correct. If you need to edit the translation you can do so in String Translation.

Can you please confirm everything is fixed?

September 5, 2019 at 12:08 pm #4519051

stephanieK-9

Hey Laura

aweome work thank you everyone for your great support.

sadly there is a strange mix up here.

- ENGLISH PAGE:
1. Only on start page, button "CONTACT" has wrong language
2. Footer is German again

- GERMAN:
"KONTAKT" is right but link leads to /contact" instead to "/de/kontakt"

I try my best to solve it, but really appreciate another look from you!

thank you

Jakob 🙂

September 5, 2019 at 12:47 pm #4519345

stephanieK-9

Update#1:

Could solve following for now:

EN
- "CONTACT" button is English and leads to English page

GER
-"KONTAKT" button is German and lead to German page

September 5, 2019 at 12:55 pm #4519357

stephanieK-9

Update #2

Mobile Menu GERMAN
"CONTACT" + link wrong language, should be:

String Translation:
header-elements-contact-multipurpose_1-caption

EN:
<a href="hidden link">CONTACT</a>

German:
<a href="hidden link">KONTAKT</a>